Skip navigation

HT2188: iPhone, iPad, iPod: How to find the software version

Learn about iPhone, iPad, iPod: How to find the software version

HT2188 What should I do if my iPod won't let me download some apps and it says I need iOS 5?

394 Views 10 Replies Latest reply: Nov 7, 2012 1:33 PM by jgwynn86 RSS
adharris624 Calculating status...
Currently Being Moderated
Nov 7, 2012 12:41 PM

I'm trying to download the twitter app again to my iPod touch but it keeps saying I need iOS 5 but I don't know what to do or how to get it, what do I need to do?

iPod touch

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.