Skip navigation

Logic Pro 7 to Logic 9

1702 Views 6 Replies Latest reply: Jan 10, 2013 12:23 PM by Rimmer2000 RSS
laurieb81 Calculating status...
Currently Being Moderated
Jul 31, 2012 11:57 PM

Hi People,

 

Just brought a new 2012 MacBook Pro with Mountain Lion installed. Gonna download Logic 9 from the app store in next few days but was wondering how easy it is to transfer my songs, audio/midi files from Logic Pro 7 sessions made on my old Macbook  into Logic 9.

 

Obviously I have tried to run Logic 7 on my new MacBook Pro but Lion no longer supports power pc apps (very frustrating Apple!!) Does anyone know of any ways to run Logic 7 on the new 2012 Macbooks & Mountain Lion before I go spend another $200 to download Logic 9.

 

 

Thanks

MacBook Pro, OS X Mountain Lion
  • bamim2 Calculating status...
    Currently Being Moderated
    Aug 4, 2012 3:11 PM (in response to laurieb81)

    Since this has been getting no responses, I thought I'd offer a "best of poor choices" suggestion...

     

    You might try the 'old fashion way'. Call your local Apple stores &/or Music stores in your area (Sam Ash, Guitar Center, etc) & see if you can find one that has Logic Pro 9 installed. Copy one of your songs to a USB thumb drive & take it down & see if they'll let you load it.

     

    In fact, you might still have time today, to just call your local music store & see if their person could actually tell you.

     

    I know my suggestion is lame. Sorry. It's a dumb enough suggestion that it might work though.

  • jdredge Calculating status...
    Currently Being Moderated
    Aug 5, 2012 1:22 PM (in response to laurieb81)

    I upgraded from LP7 to 9 a couple years ago and I didn't have any trouble importing my old projects.  I think the install locations of Logic's instruments/presets/etc. may be different in 9 than it was in 7, but this isn't difficult to work around.  I don't remember running into any other problems, but are there specific things you're concerned about?

     

    One thing to note: if you save an old project in LP9, it will be a "Save As" operation because 9 uses a different file format. I made a backup of all the original LP7 files and removed them from my main Logic folder, but I don't think I've ever needed to reopen any of them.  I have an old PowerBook that still runs LP7, so I can if I need to.

  • Rimmer2000 Calculating status...
    Currently Being Moderated
    Nov 7, 2012 5:52 PM (in response to laurieb81)

    I run Logic 7 on a 2008 Macbook Pro running Mountain Lion and it works fine. If you try to install the app from the DVD then it says it's not compatible (PPC) however Logic 7 is Intel compatible and Apple know it.

     

    This is what I did.

     

    I used my GF's iMac (2006 running 10.6). I installed Logic 7 on to that computer and then copied the application and related files on to an external HD (you can find them in application support I think as well as in plugins, check out where Logic installs all it's bits by searching with Google. That's what I did. I could be more specific but I don't have the computer with me at the moment).

     

    Copy all the files and application to your Macbook pro to the same folders as Logic installed them on the other computer, insert the dongle and run Logic. Worked for me..

     

    APPLE. If you are listening. You're very cheeky to tell people that you have to upgrade to the newer version when the software can work perfectly with people's exisiting OS and hardware. The installer wont work but you could have saved some of your existing customers a load of cash and disappointment by letting them install the application by providing an installer or at least telling people how it can be achieved. Life isn't all about money.. It's about fun and satisfaction and remember that we already paid..

  • casino_man_dan Calculating status...
    Currently Being Moderated
    Jan 10, 2013 11:51 AM (in response to Rimmer2000)

    this might be old news but just for reference, the original Logic Pro 7 install disc wasn't compatible with intel (I think it was on the market prior to intels being available).

     

    When apple released Intel mac's, Logic users needed to upgrade to Logic 7.2 (disc was about £20 I think) for it to be compatible.

     

    So long and short of it is, make sure you have the 7.2 disc, not just the original to move over to intels. Probably an ebay job these days I imagine....

  • Rimmer2000 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 10, 2013 12:23 PM (in response to casino_man_dan)

    That's good information casino man. I didn't know that.

     

    I've since upgraded to 9 and to be honest, it's notably better than 7.

     

    All the best. Rimmer

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.