Skip navigation

Magic Mouse Right Click Not Working

7732 Views 8 Replies Latest reply: Feb 8, 2013 12:49 AM by th0rb3n RSS
peterobinson Calculating status...
Currently Being Moderated
Nov 7, 2012 12:49 PM

Hi All,

Yesterday (Nov 6th) I updated my mid-2011 iMac from 10.8.1 to 10.8.2 and restarted after the update was complete.

 

Ever since then, the right click (secondary click) button on my magic mouse has completely stopped working.

 

I've tried everything obvious - checking that secondary click is enabled in the mouse preferences, deleting the magic mouse and bluetooth plist files to allow OS X to regenerate them on reboot, set the secondary click to off, rebooted then turned it on again, reset the NVRAM, I've even tried it with multiple magic mice to see if that would fix the problem.

 

Nothing I've tried works. Still stuck with no right click.

 

As I'm sure you can imagine, this is infuriating. I know that I can get the right click menu up by holding ctrl+left click but years of habit of just being able to right click leaves me fumbling around for the ctrl key when I need to right click and in all honest, this is an Apple product - it should "just work".

 

I've submitted a bug report to Apple and have as of yet, received no response.

 

Has anybody else had this issue? Has anybody found a fix for the issue?

 

Any help would be much appreciated.

 

Thanks

Pete

Magic Mouse, OS X Mountain Lion (10.8.2), Secondary Click not working

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.