Skip navigation

OS X Mountain Lion and multiple google Calendars

6459 Views 15 Replies Latest reply: Jun 27, 2013 3:19 AM by USKiwiBarlow RSS
1 2 Previous Next
msallo Calculating status...
Currently Being Moderated
Jul 30, 2012 7:01 PM

If I have more than one google calendar for an account, how can I have all of them show on the new Mountain Lion calendar?  It only adds my default calendar.  I would like it to have the same calendars as my google sync.

OS X Mountain Lion
  • Eclipse97z Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jul 30, 2012 7:23 PM (in response to msallo)

    Hey Msallo!:D

     

    I think the trick to solve this is to go to your Calendar Preferences.  Once you are in there, select ACCOUNTS.  You should see your Google (CalDAV) account on the left side.  If not, click the + sign and either select Automatic or select Google from the Account Type drop-down box.  Add your Google email address; Mac should detect that your address is a Google account and load it on the left side in your ACCOUNTS box.

     

    Once you see that your Google(CalDAV) is located on the left side and selected, select the DELEGATION tap.  You may need to give the app a minute to load and populate all of your calendars from Google.  But once they are loaded, you may select all of them that are associated with your account.

     

    Thats all there is to it!:D

  • Eclipse97z Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jul 30, 2012 7:32 PM (in response to msallo)

    Glad I could help! You're more than welcome!

  • sensslen Calculating status...
    Currently Being Moderated
    Aug 1, 2012 1:49 PM (in response to msallo)

    I wonder how you got Google Calendar working at all with ML. I always get a message telling that there wasn't any CALDav Server found.

  • Eclipse97z Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 1, 2012 9:01 PM (in response to sensslen)

    Hi Sensslen!

     

    How about trying to delete the Google account within the Calendar app and re-admiting it.  Lets start by going to Preferences in Calendar.  Once there you should see an ACCOUNTS tab; click on it. Now here you should see your iCloud (CalDAV) and Google (CalDAV), that is if its there.  If it is {Google}, lets delete it by selecting Google (CalDAV) and click the minus ( - ).  Once you have done this, we'll add it back correctly by clicking ( +).  Here you are presented with a drop down box located at the Account type.  Click on it and select Google.  Enter in your login information and everything should be easy-breezy from there.

     

    The only notion I can think that Google would NOT work is if you had set up 2-step verification via Google.  If so, you would have to go into you Google account and randomly generate the password from there, copy and paste it into Calendar.

     

    I hope this helps.:D

  • sensslen Level 1 Level 1 (10 points)

    First of all, thanks for your suggestions. But I guess I can exclude both of your solutions. I have already tried to add the Account manually. 2nd it worked in Lion and stopped working in ML so I guess it can't be because I activated 2-step setup.

  • heels12 Calculating status...
    Currently Being Moderated
    Aug 8, 2012 9:46 AM (in response to msallo)

    msallo: I will match your "multiple google calendars" issue, and raise you one more. I am currently having your same original problem (am looking forward to trying the solution tonight at home), but additionally my default calendar has now disappeared when I try to access it online through Google. Has anyone had this issue and figured out a solution? Thanks in advance...

  • BeagleIL Calculating status...
    Currently Being Moderated
    Sep 29, 2012 10:17 AM (in response to Eclipse97z)

    This is the first iCal help I've seen that has gotten me to the point of being able to see secondary calendars from my Google account. I went into Delegation just as you said and there they all were! Thanks for that. I clicked the box under "Show" for all of them and exited out. Now in the left panel of iCal I can see all the calendars too. I thought my problems were solved and left the house. When I came back, iCal looked exactly the same. In that I mean none of the calendar events from my newly enabled calendars are showing up. I have iCal set to sync every 15 minutes so I know without doubt that that it has had a chance to sync since I was gone for several hours. I even tried to manually sync but the events still do not show up.

     

    Any thoughts or ideas?

  • Sunshime Calculating status...
    Currently Being Moderated
    Sep 29, 2012 3:38 PM (in response to BeagleIL)

    I have the same exact problem. When I add my account through Google (so not as exchange) the calendar appears under delegations but no events show. I have tried a billion ways and it doesnt work.

  • Tony Reidsma Calculating status...
    Currently Being Moderated
    Oct 3, 2012 7:28 AM (in response to msallo)

    I have the same issue as Sunshime

     

    I see the delegates, but I can't do anything with them. Can't uncheck the box, can't see any events... nothing. The only thing I can do anything with is the main calendar from google, but none of the sub calendars.

     

    I used to have no issues in Lion, and I haven't changed anything.

     

    help?

     

    Tony

  • Śāntanu Calculating status...

    I am having the same issue as Tony and Sunshine. The only difference is that it was working fine in Mountain Lion, then I went to add a newly created calendar that I made in Google Calendar, and everything disappeared. Now all the "Delegates" are greyed out. I can't uncheck them or anything. I've tried deleting and readding the account, but no luck seeing the events from my Google Calendars. The only one that works is the main Google calendar.

     

    Perhaps it's a bug of some sort, or are we doing something wrong?

  • Alistair Wright Calculating status...
    Currently Being Moderated
    Nov 8, 2012 3:31 AM (in response to msallo)

    Hi,

     

    I'm also getting the same problem as Sunshime, Tony & Śāntanu...

     

    Originally I was getting constant "the server responded with an error" messages, but after some tinkering (of which I've forgotten what I did), it is now in this state.

     

    Anyone managed to get to the bottom of this?

     

    As a long user of Thunderbird with the Lightning calendar, I wanted to come back to Mail/Calendar since I upgraded to Mountain Lion recently. But I fear I will have to return to them...

     

    Thanks!

  • Alistair Wright Level 1 Level 1 (5 points)

    Ah, I see a solution here: https://discussions.apple.com/thread/3886447?start=0&tstart=0

     

    Not pretty, but works great!

     

    Thanks.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.