6 Replies Latest reply: Nov 8, 2012 11:51 AM by constancefromsimsbury
constancefromsimsbury Level 1 Level 1 (0 points)

Every time I insert a new text box it defaults to Helvetica.  But I use Times most often in my desktop publishing.  How can I change the default font?


iMac, Mac OS X (10.6.8)
  • 1. Re: Changing default text font
    PeterBreis0807 Level 7 Level 7 (29,645 points)

    Menu > View > Styles Drawer

     

    Change the default fonts for the body, header etc Styles.

     

    You can save your new document as a template and make that the default document to be opened in Pages' Preferences.

  • 2. Re: Changing default text font
    constancefromsimsbury Level 1 Level 1 (0 points)

    Thank you, Peter, but that seems to give me a template for a whole text page.  My usual tasks involve inserting two or more text boxes of different sizes and shapes (like a newspaper) and I found that, in the template, only the first box was in my preferred font.  Inserting a new box brought back the Helvetica font in that box.  I'm surprised that every text box can have the same default font but that the default cannot be changed.  What were the programmers thinking?  And from the other queries about this subject, not everyone has the same default loaded in their Pages software.  Odd.

     

    But thank you for taking time to try and instruct me.

  • 3. Re: Changing default text font
    VikingOSX Level 5 Level 5 (5,505 points)

    I just selected Text Box and got the obvious Helvetica default. Then I changed it to 10pt Times Regular. With the Text Box still selected, I chose Format > Advanced > Define Default Text Box Style. I then chose


    Format > Create New Paragraph Style from Selection, and named it, “Times box.” I also checked, Apply this new style on creation.

     

    Then, I followed this by creating another Text Box, this time with Adobe Source Sans Pro, 12pt, MediumBold. Saved this paragraph style as SourceSansPro. For this style, I left the Apply this new style on creation, unchecked.

     

    A new Text Box appears as the Times box. If I select the Text Box and then click on the SourceSansPro paragraph style, the Times Text Box acquires the SourceSansPro style.

     

    So, it is possible to maintain multiple Text Box styles in Pages '09 v4.2. However, to make these survive across documents will require the creation of a new template, as Peter suggested.

  • 4. Re: Changing default text font
    constancefromsimsbury Level 1 Level 1 (0 points)

    Thanks, Viking.  I guess that will be a few mouse clicks less on a 16-page document.  Every little time saver helps.

  • 5. Re: Changing default text font
    Jeff Shenk Level 4 Level 4 (2,115 points)

    If you just want to change the style for new text boxes, it can be a little simpler.

     

    I am guessing that you are starting from a blank Page Layout template, but the same basic procedure would work even if you are using some other one.

     

    • Open a new document from the template.
    • Insert a text box.
    • The placeholder text is highlighted; format it as you like.
    • Open the styles drawer; The default style for text boxes is highlighted (for the Blank template it is Free Form). To its right is a triangle which is red because you have modified the style.
    • Click on the triangle and select Redefine Style from Selection.
    • Delete the text box.

    Now you will be looking at a document that is the same as the one you opened from the template, except that any text box you open will have your default style; if you save now as a template, any document created with this template will be the same.

     

    (Note: Actually, this will also change the default for anything else that uses Free Form for its default, such as text in a shape, but I doubt if that would be a problem for you.)

  • 6. Re: Changing default text font
    constancefromsimsbury Level 1 Level 1 (0 points)

    Jeff, you gave me just what I needed to save the font as default.  Thanks a million!