Skip navigation

Preferences not working

402 Views 4 Replies Latest reply: Nov 13, 2012 11:08 PM by Joerg Fiedler RSS
Joerg Fiedler Calculating status...
Currently Being Moderated
Nov 9, 2012 12:58 AM

Aperture 3.4.2, OS X 10.82.

Error description:

It is impossible to use any button within the Aperture preferences. I can switch between the different part (like settings, import, export eg)

But I can't change the library, can' choose an external editor, can't set anything. Everytime I press one button, Aperture hangs for a while, than do nothing.

I can choose a different library only at first time start after deleting all settings.

 

I have done so far: delete plist file, any supporting file, start and rebuild database, reset permissions and so on. I have reset permissions for Hard disk, I have used another user....

Any suggestions welcome. Thank you for reading.

  • Aye Es Oh Level 2 Level 2 (330 points)
    Currently Being Moderated
    Nov 9, 2012 8:42 AM (in response to Joerg Fiedler)

    Have you tried deleting and reinstalling Aperture yet?

  • léonie Level 8 Level 8 (46,510 points)
    Currently Being Moderated
    Nov 9, 2012 12:27 PM (in response to Joerg Fiedler)

    Joerg,

    has Aperture 3.4.2 worked at all after upgrading from 3.4.1?

     

    An unresponsive user interface typically has one of three reasons - a corrupted preferences file, or broken files in the application's package, or incompatible kernel extensions or plug-ins.

     

    Are there any diagnostic messages in the Console window, when you try to export?

     

    Since you are saying this happens also when working from a different user account, it probably is a system wide trouble. Did you install any non-Apple applications that had installers running and might have installed frameworks or kernel extensions?

     

    if you open your System Preferences, are there any additional non-Apple preference panes? In the User&Groups Perefereces pane, do you see non-Apple start-up items?

     

    If you can exclude any non-Apple software, that might be incompatible with Mac OS X 10.8.2 and need upgrading, then I'd reinstall Aperture. On the other hand, if you have incompatible third-party software installations that might have corrupted the system, it might be necessary to reinstall the system.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.