Skip navigation

Mountain Lion no Wifi after wake from sleep

101540 Views 421 Replies Latest reply: Aug 18, 2013 8:29 AM by rgotty RSS
  • garymansell Calculating status...
    Currently Being Moderated
    Nov 9, 2012 11:12 AM (in response to ilovecode)

    Ok I think I have finally solved this most frustrating of issues.

     

    Basically a nearby router that my macbook can see is incorrectly configured with the wrong country code (or someone has imported a foreign router).


    When the macbook wakes it looks for any wireless signal to understand what country it is in and then only listens on the wireless channels for the country detected.

     

    I have about 10 wireless networks around me and one of them is set for Country "TW" - I am in Country Code "GB"

     

    Most of the times the first network I see is the GB one and my laptop looks for my wireless network on the GB wireless channels and connects OK.

     

    Sometimes, my laptop detects this rogue TW router first and only listens on wireless channels that are correct for TW - it hence can't see my wireless network as it is configured on channel 48 which is not part of the TW approved set of channels:

     

    Here is a snippet from my syslog:

     

    Nov  9 18:18:11 GarysMacBook kernel[0] <Debug>: en0: 802.11d country code set to 'TW'.

    Nov  9 18:18:11 GarysMacBook kernel[0] <Debug>: en0: Supported channels 1 2 3 4 5 6 7 8 9 10 11 56 60 64 100 104 108 112 116 120 124 128 132 136 140 149 153 157 161 165

     

     

    Hence, the options are find the neighbour with the rogue router and get it fixed/binned, or choose a channel that can be seen by both the rogue router country and your own country.

     

    The GB channels are:

     

    Nov  4 14:01:23 GarysMacBook kernel[0] <Debug>: en0: 802.11d country code set to 'GB'.

    Nov  4 14:01:23 GarysMacBook kernel[0] <Debug>: en0: Supported channels 1 2 3 4 5 6 7 8 9 10 11 12 13 36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140

     

    Unfortunately for me, my Netgear WNDR3700v2 (N600) router only allows me to chose channels 36, 40, 44 or 48 - None of which are visible if my laptop detects the country as TW !!!!

     

    I need to find the neighbour with the rogue router, I guess...

     

    Oh well, at least I know what causes the problem...

     

    BTW - I could do with the forum thankyou points, so please be generous...

     

    Rgds

     

    Gary

  • garymansell Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 9, 2012 11:19 AM (in response to garymansell)

    I meant to add - look in the file /var/log/system.log and search for this line to see what country's your machines are picking up:

     

    system.log:Nov  9 11:36:57 GarysMacBook kernel[0]: en0: 802.11d country code set to 'GB'.

     

    Rgds

     

    Gary

  • WildBill Level 3 Level 3 (530 points)
    Currently Being Moderated
    Nov 9, 2012 11:25 AM (in response to ken123)

    Odd that my reply and your recent replies aren't here? Another possibility: the wifi/bluetooth boards in your Mac Mini and your MacBook Air are different?

  • jbstas Calculating status...
    Currently Being Moderated
    Nov 16, 2012 8:01 AM (in response to Thanushka)

    I have a MacBook 2008 vintage and had no problems with Lion and have latest ML 18.2.x since installing and getting worse when I shutdown all was ok on login next time but shutdowns are becoming like sleep when the macbook awakens it does not see the wifi network. I must restart the computer and then I am connected. Turning off and on wifi does not work. I did notice a drop down java notice occassionally when not connected that it can't find something. Apple where are you??? Too much partying and stock bonuses - everyone is out to lunch. fix this stupid issue.

  • NDKO Calculating status...
    Currently Being Moderated
    Nov 17, 2012 7:03 AM (in response to jbstas)

    OK, I have the late 2010 MBA... have packet loss after sleep/awake.

     

    I have a fix... I have to MANUALLY set it to sleep on the menu. Not letting it sleep by the energy setting timeout.

     

    If I manually put it to sleep, it wakes up working.

    If I walk away long enough and it kick into sleep mode. it wakes up having 50+% packet loss.

     

    repeated this and confirmed it works for me.

    Hope this help.

  • NDKO Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 17, 2012 7:29 AM (in response to NDKO)

    I forgot to mention that I have 10.8.2 OSX and when there is packet loss... the work around is either restart or manually set it to sleep and then wake it.

     

    Something is not working right on the time-triggered sleep. Hope apple fix it soon.

  • Julius Cheng Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 19, 2012 7:05 AM (in response to NDKO)

    How do you confirm packet loss?  I have a late 2010 Air also...

     

    What I see on my end is that it appears "connected" at the icon, yet there's no connection online.

     

    In any case, it'd be impractical for me to set the MBA to sleep manually, as I carry it around my work continually.  And aside from sleep, it also appears that I have this issue when I hop between access points, even when not in sleep.

     

    And as this happens at work, I can't ask them to upgrade the thousands of access points throughout the facility just for a problem with a BYOD MBA.

  • NDKO Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 19, 2012 9:51 AM (in response to NDKO)

    When I say packet loss... I open up the terminal app and do a PING yahoo.com.

    When there is network issue, the ping will give timeout.

     

    When there is timeout issue, I just manually put the lappy to sleep (using the menu>sleep) and wait for 5s and wake it. It will be all fine.

     

    Very repeatable, and very time consuming to do this 20 times a day when a client or the boss is right next to me. I hope someone at Apple actually see my bug report and working on a fix.

  • ikedlz Calculating status...
    Currently Being Moderated
    Nov 23, 2012 1:23 PM (in response to ilovecode)

    Macbook Air (1.6 Ghz, i5), 10.8.2

    I also had wake-from-sleep issue: endless rainbow cursor spin and restart required.

     

    Turning off bluetooth before sleep appears to fix the problem: perhaps related to:

     

    http://blog.avatron.com/post/28135386805/kernel-panics-mountain-lion-and-bluetoo th

  • BruceWayneUK Calculating status...
    Currently Being Moderated
    Nov 27, 2012 6:37 AM (in response to ilovecode)

    Is there a fix yet?

     

    Just upgraded. Rather annoying.

  • AGWfromCA Calculating status...
    Currently Being Moderated
    Dec 1, 2012 6:42 AM (in response to BruceWayneUK)

    It's December 1, 2012 and this issue persists. Will it ever get fixed?

  • Marcelo NS Level 1 Level 1 (40 points)
    Currently Being Moderated
    Dec 5, 2012 4:57 AM (in response to AGWfromCA)

    I bought a Mac because it looks pretty, but mainly becasue of the buggy Vista. Now becasue of Lion and MLion I am back on Windows. Here my solution, install bootcamp and use Windows until Apple decide (if ever) to fix this issue. I have been suffering from it since Lion, Mountain only make it worst... lame Apple...

  • Julius Cheng Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 7, 2012 3:00 PM (in response to ikedlz)

    My bluetooth normally remains off, yet I still have this issue at work.  (Home is fine, BTW).

     

    Found this link recently:

     

    http://reviews.cnet.com/8301-13727_7-57557838-263/one-way-to-tackle-captive-netw ork-connection-errors-in-os-x/

     

    I'm wondering if a certificate issue is causing my problems at work - though my connection is intermittent, not continuous as you'd think a certificate issue would be.  However, this article is describing what I'm seeing - "full bars", no connection.

  • satcomer Level 4 Level 4 (1,105 points)
    Currently Being Moderated
    Dec 8, 2012 6:35 AM (in response to Julius Cheng)

    Then try using another DNS server like either OpenDNS or Google Public DNS to see if that helps.

     

    Another thing for your situation is try to open /Applications/Utilities/Keychain Access and delete the certification cetificate for the iwrlesss. Then rejoin the wirreless network and add  it back to your Keychain, fresh. This also might help.

  • Julius Cheng Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 10, 2012 8:52 PM (in response to satcomer)

    Two points:

     

    1) not sure how another DNS server would help, especially since I'm trying to access applications on the corporate system's intranet (e.g. Citrix). 

     

    2) pinging 8.8.8.8 works, with no packet loss.  Applications (even Safari) don't load consistently.  And where I am in the building matters.  Some areas work, some don't.

     

    I'm thinking it's something to do with access point security somehow.

     

    Here are some screenshots of what I'm seeing.  I tried doing network diagnostics when connected like this, but was told I was not connected to the network.

    Screen Shot 2012-12-10 at 11.33.10 PM.PNG

     

    Screen Shot 2012-12-10 at 11.40.29 PM.PNG

1 ... 22 23 24 25 26 ... 29 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (23)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.