4 Replies Latest reply: Nov 13, 2012 11:08 PM by Joerg Fiedler
Joerg Fiedler Level 1 Level 1 (5 points)

Aperture 3.4.2, OS X 10.82.

Error description:

It is impossible to use any button within the Aperture preferences. I can switch between the different part (like settings, import, export eg)

But I can't change the library, can' choose an external editor, can't set anything. Everytime I press one button, Aperture hangs for a while, than do nothing.

I can choose a different library only at first time start after deleting all settings.

 

I have done so far: delete plist file, any supporting file, start and rebuild database, reset permissions and so on. I have reset permissions for Hard disk, I have used another user....

Any suggestions welcome. Thank you for reading.

  • 1. Re: Preferences not working
    Aye Es Oh Level 2 Level 2 (330 points)

    Have you tried deleting and reinstalling Aperture yet?

  • 2. Re: Preferences not working
    Joerg Fiedler Level 1 Level 1 (5 points)

    No. First I would like to handle problems in a non-Windows way

  • 3. Re: Preferences not working
    léonie Level 9 Level 9 (51,740 points)

    Joerg,

    has Aperture 3.4.2 worked at all after upgrading from 3.4.1?

     

    An unresponsive user interface typically has one of three reasons - a corrupted preferences file, or broken files in the application's package, or incompatible kernel extensions or plug-ins.

     

    Are there any diagnostic messages in the Console window, when you try to export?

     

    Since you are saying this happens also when working from a different user account, it probably is a system wide trouble. Did you install any non-Apple applications that had installers running and might have installed frameworks or kernel extensions?

     

    if you open your System Preferences, are there any additional non-Apple preference panes? In the User&Groups Perefereces pane, do you see non-Apple start-up items?

     

    If you can exclude any non-Apple software, that might be incompatible with Mac OS X 10.8.2 and need upgrading, then I'd reinstall Aperture. On the other hand, if you have incompatible third-party software installations that might have corrupted the system, it might be necessary to reinstall the system.

  • 4. Re: Preferences not working
    Joerg Fiedler Level 1 Level 1 (5 points)

    So, after a long journey into the deep of my computer....hahaha....

    Because any installtion, removing prefs etc didn’t work, I simply use Path Finder to deeply look into all (hidden) folders and search for any file, which name has written "aperture" in it. And voila, in some folders within the /Library and /Home/Librry several files didn’t become deleted, when removing Aperture. ANd guess what: After deleting of all files found and after restart I copied a fresh Aperture on my disk, make the update and it works again.

    Thanks to all who want to help me.