1 Reply Latest reply: Nov 9, 2012 10:25 PM by John Galt
Rocam1129 Level 1 Level 1 (0 points)

I have a 2yr. Old iPad how can I get the new angry birds star wars app. It says I need iOS 4.3 ? How do I get it? Rocam1129


iPad, iOS 4.3, How do I download it to my iPad?