13 Replies Latest reply: Nov 11, 2012 1:40 PM by Vero-D
Vero-D Level 1 Level 1 (0 points)

My problem is that I'm being redirected at anytime, it can be from a bookmark page, from typing on the address bar, from a google search, it doesn't matter but it is getting very annoying.

 

I changed my DNS to an openDNS, but the problem persisted. I instlled and runned ClamXav, it didn't find any malware or problem. I decided to create a new aiport conection with openDNS. The problems is still going on.

 

Any sugentions in what to do next? I tried updating my router firmware but on my router's website I don't see a tab or an option for "Firmware" (I have a motorola router with AT&T).

 

I will appreciate any help with this. Thanks!


MacBook, Mac OS X (10.5.8)
  • 1. Re: Firefox & Safari keep redirecting me to randoms websites
    MadMacs0 Level 4 Level 4 (3,735 points)

    Vero-D wrote:

     

    My problem is that I'm being redirected at anytime, it can be from a bookmark page, from typing on the address bar, from a google search, it doesn't matter but it is getting very annoying.

    There seems to be alot of this going around recently. One user today felt he had tracked it down to a cookie action. He was able to temporarily get rid of it by trashing cookies in each browser, but it usually returned after a random amount of time. A few hours ago he said he thought he might have found a fix for Firefox which you can read here: https://discussions.apple.com/message/20225006#20225006

  • 2. Re: Firefox & Safari keep redirecting me to randoms websites
    Vero-D Level 1 Level 1 (0 points)

    Thanks. I tried something new. Let's hope it works.

  • 3. Re: Firefox & Safari keep redirecting me to randoms websites
    Vero-D Level 1 Level 1 (0 points)

    Well trashing cookies solve the problem for only a couple of hours!

    It's getting worse everytime I try something new.

    Any more ideas please?

  • 4. Re: Firefox & Safari keep redirecting me to randoms websites
    MadMacs0 Level 4 Level 4 (3,735 points)

    Vero-D wrote:

     

    trashing cookies solve the problem for only a couple of hours!

    I think that's ample evidence that it could well be cookie related, but were you able to inspect Firefox for whatever strangeness he mentioned?

     

    If not, try this:

    • In the Firefox URL window type "about:config" without the quotes.
    • In the filter box type "keyword" without quotes
    • Find "Keyword.URL"
    • Copy and paste whatever you find in the "Value" column in a reply here.

    ---------------------------------

    A suggestions I gave in that other thread was to check for EverCookies. These are hidden locations that are not deleted by normal Reset methods that have the ability to restore deleted or expired cookies. You can read about it in the references I gave in that other thread, but first check these locations for any data you don't recognize:

     

    ~/Library/Safari/Databases/

    ~/Library/Safari/LocalStorage/

    ~/Library/Preferences/Macromedia/Flash\ Player/\#SharedObjects/

     

    where "~" is your home folder at /Users/<yourusername>

     

    There will almost certainly be data there, all of which can be safely deleted and will be replaced if needed by those sites.

    ----------------------------

    Intego published a blog article that may end up helping. I have never had your redirect problem and part of the reason may be because I have taken most, if not all of these steps already.

     

    Top 5 Fast and Easy Ways to Improve Your Privacy Online

  • 5. Re: Firefox & Safari keep redirecting me to randoms websites
    Vero-D Level 1 Level 1 (0 points)

    This is what I have in the value column: http://www.goodsearch.com/search.aspx?toolbarcharity=___toolbarcharity___&id=goo dsearchtb&v=2_1&keywords=

     

    It's a browser I have had for a long time, long before this problem with the redirectin appeared.

     

    About the Evercookies,

    I checked the forlder that you recomended, and all the dara there seems familiar. I deleted some of them just in case.

     

    I also followe the intruction from Samy’s evercookie demo page. Hopefully it will work. I will let you know.

     

    Thanks again.

     

    One more thing: I opened the "hosts" file again and this is what I see now

     

    ##

    # Host Database

    #

    # localhost is used to configure the loopback interface

    # when the system is booting.  Do not change this entry.

    ##

    127.0.0.1    localhost

    127.0.0.1 activate.adobe.com

    127.0.0.1 practivate.adobe.com

    127.0.0.1 ereg.adobe.com

    127.0.0.1 activate.wip3.adobe.com

    127.0.0.1 wip3.adobe.com

    127.0.0.1 3dns-3.adobe.com

    127.0.0.1 3dns-2.adobe.com

    127.0.0.1 adobe-dns.adobe.com

    127.0.0.1 adobe-dns-2.adobe.com

    127.0.0.1 adobe-dns-3.adobe.com

    127.0.0.1 ereg.wip3.adobe.com

    127.0.0.1 activate-sea.adobe.com

    127.0.0.1 wwis-dubc1-vip60.adobe.com

    127.0.0.1 activate-sjc0.adobe.com

    127.0.0.1 hl2rcv.adobe.com

    255.255.255.255    broadcasthost

    ::1             localhost

    fe80::1%lo0    localhost

     

    # Block Adobe Activation

    127.0.0.1    activate.adobe.com

    127.0.0.1    practivate.adobe.com

    127.0.0.1    ereg.adobe.com

    127.0.0.1    activate.wip3.adobe.com

    127.0.0.1    wip3.adobe.com

    127.0.0.1    3dns-3.adobe.com

    127.0.0.1    3dns-2.adobe.com

    127.0.0.1    adobe-dns.adobe.com

    127.0.0.1    adobe-dns-2.adobe.com

    127.0.0.1    adobe-dns-3.adobe.com

    127.0.0.1    ereg.wip3.adobe.com

    127.0.0.1    activate-sea.adobe.com

    127.0.0.1    wwis-dubc1-vip60.adobe.com

    127.0.0.1    activate-sjc0.adobe.com

    127.0.0.1    hl2rcv.adobe.com

     

    What should I do?

  • 6. Re: Firefox & Safari keep redirecting me to randoms websites
    MadMacs0 Level 4 Level 4 (3,735 points)

    Vero-D wrote:

     

    This is what I have in the value column: http://www.goodsearch.com/search.aspx?toolbarcharity=___toolbarcharity___&id=goo dsearchtb&v=2_1&keywords=

     

    It's a browser I have had for a long time, long before this problem with the redirectin appeared.

    So that's a search site that you purposely adopted. It checks out with Google Safe Browsing and WOT, has a low level of tracking cookies and looks to be quite a worthwhile site. I can't see how it could be causing any of your issues.

    About the Evercookies,

    I checked the forlder that you recomended, and all the [data] there seems familiar. I deleted some of them just in case.

     

    I also followe the intruction from Samy’s evercookie demo page. Hopefully it will work. I will let you know.

    Good.

    One more thing: I opened the "hosts" file again and this is what I see now

     

    ##

    # Host Database

    #

    # localhost is used to configure the loopback interface

    # when the system is booting.  Do not change this entry.

    ##

    127.0.0.1    localhost

    127.0.0.1 activate.adobe.com

    ...

    What should I do?

    That's not your problem either, as it will simply redirect all calls to those site back to your computer, effectively blocking access to those sites. To see what that would seem to suggest, see this article. Looks like whatever caused it was run twice. If you would like to get rid of those entries let me know and I'll give you the steps you need to take to return it to it's original condition.

  • 7. Re: Firefox & Safari keep redirecting me to randoms websites
    roam Level 6 Level 6 (13,545 points)

    re: # Block Adobe Activation...

    Arhh Madmacs0 I see ye spied a pirate thar. Ye have a fine eyeglass there laddy!

  • 8. Re: Firefox & Safari keep redirecting me to randoms websites
    WZZZ Level 6 Level 6 (12,225 points)

    In addition to MadMacs suggestions, for Firefox get the Better Privacy Add-on. It will remove all Flash cookies on browser quit.

     

    And there is this more permanent solution for eliminating Flash Cookies. See Kurt Lang's post, illustrated with screenshots, which is based on the method I have been using.

     

    https://discussions.apple.com/message/19349393#19349393

     

    EDIT: Oh, since this is Leopard, I don't think you will have that Preference Pane for Flash.

     

    Do this then  (courtesy of Anonymous at XYM'ers)

     

    OK, here's the simplest solution to the annoying "allow third-party Flash content to store data on your computer" problem: lock the folders.

     

    It is simple. It also solves the issue of persistent tracking objects being installed in Flash without configuring Flash in any way. Or if you like persistent tracking objects, it causes the problem that they cannot be stored. I don't like them, so it's pretty much ideal for me.

     

    Here's what you do:

     

        Delete your ~/Library/Preferences/Macromedia folder so you're starting from a clean, shared-object-free, slate.

        Next, in your web browser visit http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_man ager02.html the Global Privacy Settings, click the button labeled "always deny" then "confirm" to prevent Flash from watching you through your webcam or listening to you over the computer's microphone. Technically speaking this isn't necessary, but it seems like a prudent move if you don't like the idea of web sites accessing these resources. Don't bother changing anything else in the Settings Manager because the other stuff pretty much involves what and how much can get saved on your computer, and we're going to answer those questions entirely different means.

        Now navigate in the Finder back to your ~/Library/Preferences/Macromedia folder and and recursively lock every file and folder inside it. This should include macromedia.com/support/flashplayer/sys/settings.sol, macromedia.com/support/flashplayer/sys, macromedia.com/support/flashplayer, macromedia.com/support, macromedia.com/#SharedObjects/<random letters and numbers>, macromedia.com/#SharedObjects, and finally the macromedia.com folder itself.

     

     

    That's it!

     

    The cool thing about this is that Flash is convinced it can store this crap so everything works, but nothing is actually remembered by Flash. Or at least nothing is remembered between browser sessions. Flash apparently never tells sites attempting to store stuff that, even though storing is enabled, it doesn't actually work and nothing gets stored. Nifty.

     

    Message was edited by: WZZZ

  • 9. Re: Firefox & Safari keep redirecting me to randoms websites
    Vero-D Level 1 Level 1 (0 points)

    Since yesterday, I have been redirected only twice. Which is not bad at all after being redirected every 10 minutes!

    Of those 2, "Ghostery" prevented one, so I actually was redirected only once. I can live with that.

     

    I read the article you suggested, and even when I don't undesrtand everything (I'm not a exppert on this stuff), I think it would be a good idea to get rid of those entries. So, I would appreciate your help (AGAIN) on returning "hosts" to its original condition.

     

    You have been such a help. Thanks you so much!

  • 10. Re: Firefox & Safari keep redirecting me to randoms websites
    Vero-D Level 1 Level 1 (0 points)

    re: # Block Adobe Activation...

    Arhh Madmacs0 I see ye spied a pirate thar. Ye have a fine eyeglass there laddy!

    Pardon my ignorance, but I don't even know what "re: # Block Adobe Activation" means?

  • 11. Re: Firefox & Safari keep redirecting me to randoms websites
    roam Level 6 Level 6 (13,545 points)

    Pardon my ignorance, but I don't even know what "re: # Block Adobe Activation" means?

    Your host file that you posted earlier shows it has employed the means to prevent Adobe Creative Suite 4 products from verifying the licence key, as explained at this link. http://www.megaleecher.net/Adobe_CS4_Keygen

    The tinkerings of a previous user no doubt?

  • 12. Re: Firefox & Safari keep redirecting me to randoms websites
    MadMacs0 Level 4 Level 4 (3,735 points)

    Vero-D wrote:

     

    I would appreciate your help (AGAIN) on returning "hosts" to its original condition.

    Sure. Here are the steps, courtesy of Linc Davis:

    Select "Go to Folder..." from the Finder menu bar. In the text box, enter "/etc" (without the quotes.) A Finder window will open on the "etc" folder.

     

    Double-click the file named "hosts" in that folder. It should open in TextEdit. At the top of the file, you should see something like this:

     

    ##

    # Host Database

    #

    # localhost is used to configure the loopback interface

    # when the system is booting.  Do not change this entry.

    ##

    127.0.0.1                     localhost

    255.255.255.255           broadcasthost

    ::1                               localhost

    fe80::1%lo0                  localhost

     

    Above and below that, you'll see some other lines. Delete everything all of those. Don't try to save; you won't be able to. Instead, select "Save As..." from the file menu in TextEdit. In the Save dialog, deselect the option to add a ".txt" extension to the file name, if it's selected. Save the file to your Desktop. You should now have a file named exactly "hosts" with no extension on your Desktop, having the contents shown above.

     

    Now comes the part that usually scares people. Launch the Terminal application, copy or drag -- do not type -- the line of text below into the window, and press return:

     

    sudo sh -c ' cat Desktop/hosts > /etc/hosts '

     

    You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. Don't panic when you see that warning. Quit Terminal.

     

    Do not type anything into the Terminal window except your password.

     

    That will fix your hosts file.

  • 13. Re: Firefox & Safari keep redirecting me to randoms websites
    Vero-D Level 1 Level 1 (0 points)

    Thank you! =)