Skip navigation

Force reinstall of GeForce 7300 GT on Mac Pro 1,1?

890 Views 12 Replies Latest reply: Dec 9, 2012 3:22 PM by Grant Bennet-Alder RSS
agrantfan Calculating status...
Currently Being Moderated
Nov 11, 2012 6:18 AM

Is there a way to force my Mac Pro to reinstall the software for the GeForce 7300 GT graphics card?

 

I'm dealing with a gray screen and spinning color wheel at startup and I've tried everything. It boots fine in Safe Boot and I was able to back everything up.

 

I've cleared PRAM (multiple times in a row), I've restored from Time Machine backups, bought a brand new hard drive and tried a clean install and still the same gray screen at startup.

 

I've read many support articles and the graphics card seems to be a common isuse. Before I replace it I'd love to force it to reinstall the software but when I downloaded and ran it I receive the message, "This computer does not need this update." Is there a way to force it to run it again? Or remove it and reinstall it to see if a setting is corrupt?

 

Short of that I'm thinking of buying the ATI Radeon 5700 but I don't want to spend more money without knowing for sure it will help my issue.

Mac Pro, Mac OS X (10.7.5), 2 GB 667 MHz DDR2 FB-DIMM memory
  • Grant Bennet-Alder Level 8 Level 8 (48,110 points)
    Currently Being Moderated
    Nov 11, 2012 6:31 AM (in response to agrantfan)

    Along with many other kernel extensions, it will be removed and set aside if you boot into Safe Mode. (Hold down Shift at Satrtup).

     

    When you next boot into "normal" mode, the set of Drivers loaded all-at-once will be rebuilt from scratch.

     

    That is about the best you can do without re-Installing Mac OS X in its entirety (which may not be a bad idea anyway).

    Mac Pro (Early 2009), Mac OS X (10.6.8), & Server, PPC, & AppleTalk Printers
  • Linc Davis Level 10 Level 10 (107,840 points)
    Currently Being Moderated
    Nov 11, 2012 7:46 AM (in response to agrantfan)

    Reinstalling system components is rarely the solution to any problem. Boot in safe mode and post the log messages from the last failed boot attempt, starting with "BOOT_TIME" and ending with the next "BOOT_TIME".

  • Linc Davis Level 10 Level 10 (107,840 points)
    Currently Being Moderated
    Nov 11, 2012 10:00 AM (in response to agrantfan)

    This is after a clean installation on a new drive?

  • Linc Davis Level 10 Level 10 (107,840 points)
    Currently Being Moderated
    Nov 11, 2012 10:19 AM (in response to agrantfan)

    You have massive system corruption. If it was like that right after the clean installation, before you restored from backup or did anything else, then your drive is malfunctioning or you have some other hardware fault. I suggest you do another clean installation on a different drive and test.

  • Linc Davis Level 10 Level 10 (107,840 points)
    Currently Being Moderated
    Nov 11, 2012 8:01 PM (in response to agrantfan)

    Make a "Genius" appointment at an Apple Store to have the machine tested.

    Back up all data on the internal drive(s) before you hand over your computer to anyone. If privacy is a concern, erase the data partition(s) with the option to write zeros* (do this only if you have at least two complete, independent backups, and you know how to restore to bare metal from any of them.) Don’t erase the recovery partition, if present.

    *An SSD doesn't need to be zeroed.

  • Malcolm J. Rayfield Level 5 Level 5 (4,510 points)
    Currently Being Moderated
    Nov 15, 2012 10:08 PM (in response to agrantfan)

    So I navigated to /System/Library/Extensions and moved all the files starting with NV and GeF to a backup directory on my desktop, then used Kext Wizard option "System/Library/Extensions" to Repair Permissions and to Rebuild Cache, then rebooted.

     

    It works normally now! No more need to boot in Safe Boot.

    Removing the NV... extensions or using Safe Boot will disable hardware graphics acceleration.  This may make some defective graphics cards appear to work, but at reduce speed.

     

    Safe Boot:

    <http://support.apple.com/kb/HT1564>

    "It loads only required kernel extensions (some of the items in /System/Library/Extensions).

    ...

    Safe Mode in Mac OS X v10.5 or later also disables Quartz Extreme (hardware accelerated graphics). Applications that depend on Quartz Extreme will not open, and the Mac OS X menu bar will appear solid even if "Translucent Menu Bar" is enabled in Desktop & Screen Saver preferences."

     

    Does Translucent Menu Bar still work on your system?

  • Grant Bennet-Alder Level 8 Level 8 (48,110 points)

    Since the kexts you modified are not even for your Hardware, i expect this is solved gain because you are not running accelerated graphics. This may work for a while, but ultimately I expect you will need to replace that 7300 card prefereably with something a little more modern.

    Mac Pro (Early 2009), Mac OS X (10.6.8), &amp; Server, PPC, &amp; AppleTalk Printers

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.