6 Replies Latest reply: Nov 11, 2012 8:15 AM by mende1
Starnie Level 1 Level 1 (135 points)

I am running 10.6.8 on my iMac and it appears that my machine meets the minimum requirements to run Mountain Lion.  Will these apps continue to work and are they automatically upgraded to a newer version upon completion of downloading Mountain Lion?

 

I also understand that and PowerPC apps are incompatible.  Do I need to delete them?  Anything else?

 

iTunes:  10.7

iCal:  4.0.4

iPhoto:  7.1.5

Pages:  3.0.3

Numbers:  1.0.3

Mail:  4.6

Garage Band:  4.1.2

Time Machine:  1.1