Skip navigation

Ethernet connected Apple TV 3 can’t play content.  WiFi works fine.  What gives?

10629 Views 27 Replies Latest reply: Mar 19, 2013 11:50 AM by DJChad RSS
1 2 Previous Next
dustin100 Calculating status...
Currently Being Moderated
Oct 2, 2012 2:24 PM

Apple TV 3 has a strange problem since the latest update, 5.1.  It is only partially functional when hard wired to my router, but is fully functional when connected wirelessly.

 

When hardwired, I can control it with the iOS Remote app, airplay from iPhones & iPad, and browse the menus of the various services, Hulu, Netflix, etc. But, when I try to play content, for example, a  Hulu show, I get a “there was an error…” message. 

 

When I connect wirelessly- everything works fine- I can play all the content without a problem.

 

I prefer to have a wired connection, and have been using one successfully up until 5.1 – does anyone know how to fix the  limited functionality of the wired connection? 

Apple TV 3
  • Roy B Level 3 Level 3 (570 points)

    Hello all,

     

    It appears that this issue is related to specific network/Internet configurations. If you are experiencing this issue (some features work over WiFi but not Ethernet) after updating to Apple TV version 5.1, please send me <royb@apple.com> an email with this information:

     

    1. What is the manufacturer, model number and firmware version (if possible) of your Ethernet router?

    2. What is the manufacturer, model number and firmware version (if possible) of your WiFi router? (if it is different)

    3. What is your Internet service provider?

    4. Where are you located geographically? (what city?)

    5. What Internet features do work over Ethernet?

    6. What Internet features do not work over Ethernet?

    7. Does it read "Activation Failed" at the bottom right in Settings > General > About?

     

    Please make the subject line of your email be "Some features work over WiFi but not Ethernet".

     

    Thanks,

    Roy

  • rtyelland Calculating status...

    Hi Roy

    I have the same issue. Apple tv 3 updated to 5.1 3 days ago.

     

    When on wifi - Photostream- MLB & News You tube work - not currently subscribed to

     

    Ethernet - get the cannot connect to server for photostream - unable to sign into Youtube Unable to accces MLB or the News channel;

     

    YES_  Does it read "Activation Failed" at the bottom right in Settings > General > About?

     

    I'm on Sky - Location UK-

    I'm at work  - so I'll feedback make/ model/ etc of router later today

    Regards

    Richard

  • rtyelland Level 1 Level 1 (0 points)

    Roy

     

    Case number @ Apple 357624395

     

    Updated 7/10/12

    router Details FYI

     

    System Details
    ManufacturerSagemcom
    Model NumberF@ST2504n
    Firmware Version6.14.1a4N_UNI
    ADSL Firmware VersionA2pD035g.d23j1

     


     

     

    As per others if I connect via wifi all works
    If i go back to ethernet get the cannot connect to server for Photostream for screen saver

    But the activation message is not there any longer

     

    Very frustrating - my ethernet connection is 14meg plus!

    In addition to the apple tv I have apple touch & ipad2 all on 6.0

    Plus itunes on pc with latest version.

    Subscribe to imatch - so some of the potential fixes online which may be relevent re T & C's not workable.

     

    Raised a case with apple as does not look like this is a PICNIC ;-)

     

    regards

    Richard

  • techmirth Calculating status...

    Just bumping this thread.

     

    Apple, AirPort Extreme, 7.6.1.

    25M down and 5M up on Xfinity.

    The internet test works, it pulls cover images for some apps, other apps won't even load. Won't play any movies or internet radio.

  • Brian Cook4 Level 4 Level 4 (1,820 points)

    I had this exact problem which I tracked down to a problem with my Cisco E3200 wireless router.  It apprently had some DNS bug that caused it to connect EXTREAMLY slowly or not at all to random URLs.  Not sure why it was only a problem with the Wired connection.  The problem went away after I reset my router by holding the reset button down for 30 sec.  I also found in the logs that my router has been over heating.  I had set my cable modem on top of it which was blocking the vents. 

     

    So after the reset and clearing the air vents on my router it is fine on Wired connections again.  Only ATV was having a problem with the wired conneciton.  No idea why.

     

    1. What is the manufacturer, model number and firmware version (if possible) of your Ethernet router?

    Cisco E3200 10.01b

     

    2. What is the manufacturer, model number and firmware version (if possible) of your WiFi router? (if it is different)

    Same Cisco E3200 10.01b

     

    3. What is your Internet service provider?

    Time Warrner Cable.

     

    4. Where are you located geographically? (what city?)

    Kansas City, MO.

     

    5. What Internet features do work over Ethernet?

    iMac worked fine over Eithernet, even with streaming video. 

     

    6. What Internet features do not work over Ethernet?

    Only ATV had extreamly slow connection times when trying to connect to random parts of the iTuens store (favorites, purchased shows, iTunes store, etc.)  Same with Netflix.

     

    7. Does it read "Activation Failed" at the bottom right in Settings > General > About?

    I would some times start getting the activation failed error from the iTunes Store.  I would restart AppleTV and that would fix it about half the time.

  • KJ4BUP Level 1 Level 1 (5 points)

    I am looking forward to a fix for this.  I have same issue: could not connect to photo stream, itunes, etc. until I unplugged the ethernet...voilà it works via WiFi.

  • Brian Cook4 Level 4 Level 4 (1,820 points)

    Turns out my router reset only fixed the problem for a few days.  Then the problem came back.  My iMac and my iPhone have no such issue.  Only AppleTV.

  • Sean Mccullough Level 1 Level 1 (5 points)

    Same issue, can't Activate or sign into Photo Stream when hooked up via ethernet but wifi works fine. Also cannot restore when hooked up via ethernet.  Went and bought a $15 cable to hook it up to iTunes and did a restore that way, made no difference.

     

    Cisco wifi router/ethernet hub.  Comcast in ABQ, NM. 

  • Luis Garcia2 Calculating status...

    Same problem:

     

    Airport Extreme with latest firmware

    Just bought Apple TV 2 weeks ago

    DSL from Century Link (10 Mbps)

    Phoenix, AZ

    I can browse Hulu content but can't play anything

    Can't access photo stream

    Can't access WSJ

    Tried to restore Apple TV but go a Failed message

    Tried to reset but stuck at Activation screen

    Apple trailers work

    YouTube works but very slow

    Home sharing works but very slow

     

    WiFi works great.

  • TheCleverCoder Calculating status...

    I am having the same issue. My router is a Gigabit Netgear upgraded to Tomato firmware. This issue started after I did a reset on my ATV. Everything was working on OS 5.1 but after I reset the ATV YouTube wouldn't sign in and PhotoStream wouldn't work. I thought going on WiFi was a ridiculous suggestion but it worked for me. I would MUCH rather run my ATV through ethernet so I am very eager to see a fix for this.

     

    My internet service is VDSL on Nexicom PPPoE.

  • sensires Calculating status...

    Hi Roy,

     

    I am having the same issue with a brand new Apple TV pre-loaded with 5.1.

     

    1. Ethernet Router: Cisco Linksys E4200, Firmware Version: 1.0.01 build 10  Feb 21, 2011

    2. Wireless Router: Same as above

    3. SingTel Fibre Broadband

    4. Singapore

    5. Works on Ethernet: Youtube (works only when I boot with Wi-Fi so that the internet connection is available, and if I hook up Ethernet mid-way Youtube still works, but upon a restart with Ethernet remain hooked, all internet related features get stripped away and I'm left with Computer and Setting icons, Youtube is obviously unavailable then)

    6. Fails on Ethernet: Software update fails, iTunes store not accessible, Movie Previews do not load, Trailers not accessible, and the list goes on

    7. Activation Failed initially because I hooked up Ethernet on the very first power up out of box, but I have since unhooked Ethernet and successfully connected via Wi-Fi, activation has succeeded and the message has gone away.

     

    May I also note Airplay works while connected to Ethernet, Apple TV settings also show my router successfully assigned it an IP, Gateway and DNS servers via DHCP, are all in order. Except all internet services seem unavailable.

     

    Looking forward to a fix!!

     

    Kai

  • pabzpabz Calculating status...

    Got a WiFi router being maxed out, so thought I would try connecting Apple TV to computer via ethernet to reduce the load on the wifi (sometimes very slow). I am finding the same problem. Apple TV detects library, shows available music / episodes etc but I am unable to watch any of them ("connecting...") or connect to internet services through Apple TV. Help? Apple?

  • BosseW Calculating status...

    Hi, i have same problem.

     

    I Will post router details etc tomorrow Monday.

     

    I have tried Factory reset. Does not work when on ethernet cable, but does work when i connect on WiFi.

    But even aften factory reset as soon as I plug in ethernet cable Photostream does ny work. Neither do NBA and MLB TV.

    Youtube works.

     

    I am in Denmark.

     

    Regards Bosse

  • BosseW Level 1 Level 1 (0 points)

    Hi, here comes details:

     

    1. Router Thomson TWG870TS. Firmware unknown because I don't have access to it (only my ISP provider has)

     

    2. Same as above

     

    3. Stofa Denmark

     

    4. Denmark , Snekkersten

     

    5. These works for sure: netflix, youtube, flickr, radio,

     

    6. These do not work: photo stream, NBA, MLB.tv

     

    7. No

     

    Regards Bosse

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.