Skip navigation

Can not import files from internal HD

2165 Views 35 Replies Latest reply: Nov 14, 2012 1:40 PM by leonard1212 RSS
  • léonie Level 8 Level 8 (46,330 points)
    Currently Being Moderated
    Nov 7, 2012 12:46 PM (in response to leonard1212)

    Works the same way from other user: From some folders on Internal and extern SD cards Harddrives

    it works- that is I can see the files and import them, from some folders I can´t see the pictures but the nuber of files (like iin the screenshot I sent) and finally from some folders that I have imported from before I can see nothing= no numbers of files and no pics

    When you tried this from a different user account, did you create a new Aperture Library, or did you use your main Aperture Library? Can you import into a new library?


    And what is the difference between the images in the folders that are showing up and that do not? What kind of images? Are all images standard jpeg? Or do you have raw images, if yes, what camera?

    Is there anything special about the filenames or extensions? Any ethnic characters or white space? How are your external drives formatted?



    Added: Your device "NO NAME", where "Save in Current Location" is greyed out, is that a memory card in a card reader? Is that device write protected or locked? if you cannot save to that device, you may have a permissions problem. What do you see, when you inspect it with "Get Info ⌘I" in the Finder?


    Addendum 2: What is your current iPhoto version? Is it compatible with Aperture?

  • léonie Level 8 Level 8 (46,330 points)
    Currently Being Moderated
    Nov 7, 2012 12:59 PM (in response to léonie)

    And one more question: I noticed, I cannot find your Aperture version in your posts.

  • léonie Level 8 Level 8 (46,330 points)
    Currently Being Moderated
    Nov 8, 2012 7:42 AM (in response to leonard1212)

    I have to think about this - but one small comment: This might be one of the problems:

    The No Name 32 GB USB is MSDOS only used temporarily-read and write permissions are there as with all drives.

    The most recent Aperture version seems to check the formatting of the file system. An Aperture library should only be stored on a volume formatted Mac OS X Extended, and with the newest version this check seems to be extended to the filesystem storing the referenced originals. At least I could not keep referenced originals on a MS-DOS(FAT) thumbs drive.  What happens, when you move your folder with images from the MSDOS ony drive to a Mac OS X Extended drive. Do you see the images then and can you store "In the current location"?

  • léonie Level 8 Level 8 (46,330 points)
    Currently Being Moderated
    Nov 8, 2012 12:38 PM (in response to leonard1212)

    What the difference between these folders is would be very interesting to know....

    That is the spooky bit...

    Try experimenting with one folder that you can import, and one folder that you cannot.


    You have too many variables in the picture that are unknown.

    how about creating a new, empty Aperture library on your system volume and trying to import from one of the folders that does not work.


    Can you import into that empty library? Then your main Aperture library is the problem.


    If you cannot, then try to find out if the contents of the folder is that problem, or the folder, or its location.

    Try systematically to remove items from the problematic folder and see, if you can import it this way.

    Move the items to a folder that you can import and see, if tat changes, when you move the items.

    check if the folder itself is causing the problem or the folder/disk that is containing it.

  • léonie Level 8 Level 8 (46,330 points)
    Currently Being Moderated
    Nov 9, 2012 4:51 AM (in response to leonard1212)

    could that be an issue here that Mac disk utilities can´t fix??

    The permissions check by disk utility may show errors, that are irrelevant. It checks for standard permissions, but some applications will change the permissions over and over again, if they need different permissions. A real problem may be a corrupted file system on your system drive, and that can only be repaired by booting into the recovery partion, for you cannot repair the system drive while the system is running from this drive.

  • léonie Level 8 Level 8 (46,330 points)
    Currently Being Moderated
    Nov 9, 2012 7:21 AM (in response to leonard1212)

    Would for example "DISK WORRIER" program or some other alternate Utility program..any suggestions......? do it better??

    Maybe, but I have never used those, so I cannot give a recommendation on that.


    If iPhoto sees the image files in all folders and on all drives that Aperture cannot see?

    And you see the same problem (invisible image files in the Import window) with other disks?


    Then I think it unlikely that the disks itself are faulty.


    Any progress with moving image files around between folders and disks?

  • Aye Es Oh Level 2 Level 2 (330 points)
    Currently Being Moderated
    Nov 9, 2012 8:39 AM (in response to leonard1212)

    We are all Disk Worriers


    Seriously, Disk Warrior does check drives more extensively, just make sure that you're updated to the latest version (4.4, I believe). And make sure you have a backup of your vital info before you attempt any repairs.

  • léonie Level 8 Level 8 (46,330 points)
    Currently Being Moderated
    Nov 9, 2012 8:45 AM (in response to Aye Es Oh)

    Thanks for jumping in, Aye Es Oh! We can use any help here

  • léonie Level 8 Level 8 (46,330 points)
    Currently Being Moderated
    Nov 11, 2012 1:30 PM (in response to leonard1212)

    the only problem left over is when I try to import from any of my folders withPrivate in them then the option

    "save in current location" is greyed out

    That is a promising finding! Great!


    Can you see any difference between the "video" folder and the original ""Private" folder? If you select them and inspect them with "File > Get Info"? Different permissions, lock bit?


    How did you create the folders "LX5 All", "Pentax", ...? Did you simply drag the folder from your card to the backup drive?


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.