Skip navigation

My iPhoto v9.4.2 opens in Mountain Lion OS but does not allow me to click on anything.

469 Views 11 Replies Latest reply: Nov 11, 2012 6:50 PM by Old Toad RSS
chamataka Calculating status...
Currently Being Moderated
Nov 7, 2012 3:25 PM

My iPhoto v9.4.2 opens up in my MacBook Pro running Mountain Lion OS v10.8.2, but does not allow me to click on anything within the iPhoto window or on the desktop screen. The only way I can get out of this is by sliding (using trackpad) to another full screen window and then force quitting iPhoto.


I have tried repairing my library, but the problem persists even after that. I wanted to rebuild my library, but when I click "Show Package Contents" I cannot find the original and modified photo folders. Sometimes (I have seen it in the past but I am not sure if this is a related issue) during the repairing process I see an alert saying that image XXXX.jpg cannot be found.


I have moved the iPhoto app to the trash and reinstalled it, but the problem persists.


Can someone point me in the right direction? Thanks for your help.

MacBook Pro, OS X Mountain Lion (10.8.2), iPhoto v9.4.2


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.