1 23 24 25 26 27 Previous Next 650 Replies Latest reply: Feb 11, 2014 4:45 PM by Booker T. Go to original post Branched to a new discussion.
  • 360. Re: time machine very slow with mountain lion
    LegalGeek Level 1 Level 1 (0 points)

    So, I have good news and bad news. The good news is for Apple and the bad news is for us.


    I have done some pretty extensive testing on this issue and it seems to point to some 3rd Party app or driver as the culprit.


    As my post above indicated, I wiped my hard drive clean and only performed a manual copy of my home folder. I did not copy any apps. After hours of copying and more hours of backing up, I'm able to report that TM works over the network in 10.8.2.


    I was able to back up 514.18GB of data over the network using the Thunderbolt -> Ethernet adapter on my MacBook Pro Retina. I backed up using Time Machine to my Mac Mini Server with a Drobo connected by FW800. Backup completed in just under 5 hours. That is appropriate speed in my opinion.


    I did not have ANY 3rd Party apps or drivers installed and it worked fine. So, some company isn't playing nice with 10.8.2 apparently.


    I have now installed a minimal set of apps that I need to do basic work:


    • Office 2011 + Updates
    • 1Password - App Store Version
    • Dropbox
    • Java + Updates
    • Citrix Receiver


    I am now running a completely new TM backup after deleting the sparsebundle on the server. I deleted some duplicate data (Outlook Databases) on my MBPR and it is backing up 509.98 GB this time including the apps. At this rate, it should be done well before morning. If it works, I suggest that everyone start posting all of the apps (and drivers?) that they have installed on their machines to see if we can determine some commonality.


    I'll post updates as they come.

  • 361. Re: time machine very slow with mountain lion
    David Schwab Level 1 Level 1 (110 points)

    LegalGeek wrote:


    I have done some pretty extensive testing on this issue and it seems to point to some 3rd Party app or driver as the culprit.


    I really doubt this is the problem, at least on my end. This is because Time Machine was working just fine on my Mac, via USB, and then just stopped working. Nothing else had changed. No new apps, no new drivers, etc. So if apps and drivers were the culprit, TM would have had issues all along.


    Outlook 2011 has had issues with Mountain Lion from the beginning. If the computer has been shut down, or rebooted, Outlook often takes a very long time to start up. If I just put it to sleep, it's fine. This is also true of the Finder, which hangs on me quite a lot. This all started with ML.


    I even did a clean install of ML to see if it was going to fix anything, and it didn't. So I think this TM issue is a ML issue, and as we saw, Apple released a TM fix, but not for ML. I'm afraid that it seems that with Jobs gone, things are being rushed out the door prematurely. If Apple is testing this stuff, it has to be with plain vanilla installs, and not real world installs with non Apple apps and drivers. And some of the drivers Apple is releasing via Software Update, like for Lexmark printers, are very buggy. It broke printing and scanning for me, and I had to revert to an older version from the Lexmark site.

  • 362. Re: time machine very slow with mountain lion
    Tech Harmony Level 1 Level 1 (0 points)

    Thorough LegalGeek! After all this time! Amazing you found your solution.


    To recap: something in 10.7.5 and 10.8.2 interacted with existing installs and killed Time Machine to the tune of 25 pages of Apple Discussions.


    10.7.5 users were able to fix this by disabling Spotlight until Apple released a 10.7.5 supplemental update which fixed things (that problem really was Apple's and probably related to Spotlight). Apple released a 10.8.2 supplemental update that did not address the problem at all...and remained silent.




    I thought we'd heard from several people who reformatted their systems but perhaps in each case they restored their systems from a Time Machine backup or clone that just recreated the problem? Hmmmm.


    So somehow the 10.7.5 breakdown was an Apple-only problem and the 10.8.2 breakdown is a third-party app problem?


    Seems just as likely that how you reformatted this last time is critical to 10.8.2 working better. You said you reinstalled your home user manually but, more critically, it sounds like you might not have used Time Machine at all to restore your system. Perhaps there is something in existing 10.8.x installs that doesn't get modified properly by the 10.8.2 update or a Time Machine restore. No way to tell. (historically, Time Machine is interwoven with the network driver. Don't ask me why...but to get TM to work at all on Leopard and Sleo Intel boxes, you needed the proper IONetworking kext)


    I suppose people can start uninstalling apps but if it's some deeper driver extension the apps leave behind, dragging apps to the trash won't be a good way to figure out if an app is the problem. Inevitably people are looking at a reformat that they can't use a Time Machine restore for. Because if they restore from a backup using Time Machine (or clone) -- which is the whole point of having backup -- they may simply restore the problem too.


    I feel for everyone this has affected. This isn't new to Jobsless Apple though... stuff like this has happened before (and worse) going back to 10.3.x. More often problems happen early in the update cycle but they've also happened late in the update cycle. Like unforgiveable problems. There's no way to protect yourself other than to not update if things are working well or to clone every time you intend to update. Most people won't do this because they would already have started doing it after the last update screw-ups (I'll spare you the horror stories).


    I do think LegalGeek's approach is one way to do this if you have some basic tech chops and are willing to rebuild your setup from scratch. Depending on how you go about restoring your Mountain Lion, if you can avoid 10.8.2 altogether and update a 10.8.base to 10.8.1 -- http://support.apple.com/kb/DL1571 -- then afterwards you might be able to do a post-install Migration Assistant of your existing user backup and save yourself some setup time (probably not recommended to migrate 10.8.2 apps to a 10.8.1 install but if you're game and it lets you, let us know how it works).

  • 363. Re: time machine very slow with mountain lion
    LegalGeek Level 1 Level 1 (0 points)

    Hi, David.


    I understand your points. Just curious about a few things. When you did a fresh install of ML, did you try a backup with no apps/data? That was my mistake from before. I did a fresh install of ML, but restored my apps and data from a previous backup. Apparently one or more of those apps was the culprit.


    As for my situation, I'm not sure that Outlook is the problem. I am running Outlook right now and so far, the backup is running fine.


    I also understand that nothing on your system changed and that it just stopped working. That was my experience as well when I upgraded to 10.8.2. TM just stopped working for me. However, that doesn't mean that it is necessarily Apple's doing.


    Some of the possible scenarios are:


    1. Apple added new functionality in 10.8.2 that disagrees with an existing app.

    2. Apple fixed a bug in the OS that other apps erroneously relied upon.

    3. Apple introduced a new bug that doesn't cause any problems until an app uses that specific piece of the OS.


    There may be others. I agree with Tech Harmony that this is not a new situation for any OS, really. Every OS has bugs. This one just happens to render a major feature of the OS completely unusable. Having to do a clean install is a drastic measure and one that, personally, I have never had to do on a Mac, but have had to do plenty of times on Windows machines.


    Hopefully, the backups will continue to work as I add my apps back onto the machine. If not, I'll be sure to continue to work with Apple to figure it out.

  • 364. Re: time machine very slow with mountain lion
    LegalGeek Level 1 Level 1 (0 points)

    Tech Harmony,


    I did indeed reformat my drive in the past when troubleshooting this problem. However, I restored both apps and my user data with Migration Assistant. I did not restore any system settings, etc.


    This time, however, I did not use Time Machine or Migration Assistant. Instead, I mounted the .backupdb file and pulled over the user folder. See http://www.maclife.com/article/howtos/how_manually_restore_time_machine for more info. I did not bring over any apps or any of my user settings. I then copied the contents of specific folders (Movies, Downloads, Documents, etc.) to the respective folder in my new user account.


    I would feel more satisfied if I had some sense of the cause of the problem. Right now, I just don't know and that leaves me with some concern that it will come up again in the future. Only time will tell.


    In the meantime, the backup is still progressing nicely. 350GB of 509GB completed with about an hour to go. It's been running for a little less than 4 hours, so that is on par with my previous backup.

  • 365. Re: time machine very slow with mountain lion
    bhurte Level 1 Level 1 (0 points)

    I don't buy part of this because my slow TM backups (introduced with 10.8.0) were solved with an RF solution - turning off 5GHz.  I never had slow backups prior to 10.8.0 or when I connected via a wire (Ethernet) to the Time Capsule (even from 10.8.0 to 10.8.2).  Further, I've since gone to a new laptop, done a straight migration using Migration Assistant, turned 5GHz back on, and backups are proceeding at normal (fast) speed.  Too many moving parts, but it still suggests something at Apple's end in low-level networking protocols.

  • 366. Re: time machine very slow with mountain lion
    David Schwab Level 1 Level 1 (110 points)

    I didn't do the reinstall because of Time Machine. I stopped using Time Machine by that point because it had gone for over three days without an hourly backup. That defeats the purpose for having backups, right? I moved over to Carbon Copy Cloner, which backed up my drive, I think in about 8 hours, and have been doing nightly backups with that every since. TM worked great up to ML, and then it had the annoying habit of making the Mac very sluggish while doing its backup. That was the first indication that something was amiss. That never happaned in Lion and earlier. I often had to stop the backup so I could get some work done.


    The reason I did the fresh install was for other ML bugs. Now when I installed ML, it was running great. I read about people having the spinning beachball of death, but that wasn't happening to me. And then it started. Nothing had changed on my machine as far as apps, and it wasn't from the 10.8.2 update. It started around 10.8.1. While it's not directly related to the Time Machine problem, I think they are symptomatic of something else going on system wide. The fact that I get the problems with rebooting, and then they will go away if I do a safe boot, makes me think it has to do with OS X's new feature of saving the state of the apps, etc. When you remove these, things work normally.


    ML's Finder in particular seem to have issues. Activity Monitor shows that the Finder has had 13 hangs since I restarted about 6 hours ago. Most of that time the Mac has been sitting idle.


    Also, I wasn't saying that Outlook was causing the TM issue. I was saying that Outlook has an issue with ML. Often is hangs on the "setting up identity" phase. Once again, clearing caches and removing the savedState files fixes this until the next time the Mac is shut down.


    I've been using Macs since about 1991. I've used every version of the Mac System/OS software since then, with the exception of the OS X Public Beta. OS X is far less buggy than System 7 through OS 9 was, but ML is far buggier than the past few versions.


    But if I don't shut down, everything settles in and my Mac will do what it's supposed to do. Meanwhile my son and ex wife stayed on Lion because they saw the issues I was having. I'm sure Apple will fix this eventually.

  • 367. Re: time machine very slow with mountain lion
    tariqmc Level 1 Level 1 (0 points)

    Just thought I'd add my expereince. 


    MBP with SSD and a 12TB Pegasus (400BM/sec) running 10.8.2.

    Mac Mini Server with DroboPro iSCSI (60MB/s) 16TB (thin provisioning) 10.7.5

    Conected via Gb ethernet (so theoretical max of 125MB/sec) using DHCP.


    I've got about 4.5TB of stuff to backup.


    So far Time Machine has been just stuck on 'Cleaning up' and 'Preparing'.


    I've tried stopping spotlight, using disk utilities to verify and repair source and destination disks, deleting the old sparsebundle and various other things.  None appeared to work.  I also tried ChronoSync but it went very slowly.


    I've moved over to Carbon Copy Cloner which is running at about 30MB/s using its remote connection feature.


    I've got some other laptops running Mountain Lion and they backup OK but they have very little to backup.


    Time Machine used to work and had about 8TB sparsebundle but not anymore.


    I hope a fix comes soon.  I believe its a network issue.  I will probably rebuild my network once I have a backup with CCC made.  I'lll move to static addresses and change my router.


    I'll report back if I get anything to work.



  • 368. Re: time machine very slow with mountain lion
    verdi1987 Level 1 Level 1 (10 points)

    Would you try connecting via WiFi to the Time Machine destination? My backup refused to progress when connected via Thunderbolt Ethernet but worked once I switched to wireless.

  • 369. Re: time machine very slow with mountain lion
    verdi1987 Level 1 Level 1 (10 points)

    That last post was meant for tariqmc. I hit reply on the wrong post.

  • 370. Re: time machine very slow with mountain lion
    Russa Level 4 Level 4 (1,315 points)

    I backed up my MBP and 510GBs on T/C in 6 hours over Gb ethernet.

  • 371. Re: time machine very slow with mountain lion
    Tech Harmony Level 1 Level 1 (0 points)

    @LegalGeek, aha I see.... so before, after reformats,you were just migrating apps and user settings and it still wasn't working. So last time you didn't migrate the apps and user settings, brought over files manually, and TM started working (interesting that Migration Assistant even worked, under the circumstances...).


    I guess it would be "easy" to test the user settings impact by creating a new user, logging out of the old one, and initiating a new backup. But this has surely been tried and another reason for Apple to blame apps-interaction. Something that comes to mind is Adobe -- maybe Bridge -- stores a ton of invisible cache data ....maybe some other program is doing this.


    Still I saw this breakdown happen on 4 different computers in one computer cluster the moment I got them to 10.7.5... it just seems so weird that 10.8.2 would have a different problem....but you nailed it with your breakdown...who knows what Apple updated.. around the late 10.4.x's they brought their USB ports down to normal specifications and this nuked peoples' backup drives! So correct action doesn't always yield desirable results...




    As for everyone else, I'm intrigued by these network and external drive variables (three of the computers I encountered the bug on were all working over gigabit, one over wifi) ... I wish I timed the last rounds of backups but 1TB just to another internal drive can take all day and a night...so doing it over gigabit (let alone WiFi) under ideal circumstances could take more than a day or two... guess it depends on a number of things. I use Chronosync and it's only slow for me because I have it verify all the data it copies.... so that takes awhile but when it gets going it probably runs at 10-40MB/s (I've never really seen gigabit sustain over 60MB/s so keep your expectations down).

  • 372. Re: time machine very slow with mountain lion
    tariqmc Level 1 Level 1 (0 points)

    @verdil987  Hi, thanks, yes I've tried just over WiFi and just over Gb Ethernet (both via thunderbolt adapter and via standard Gb socket on Mini), but no difference.  What confuses me is that TM was going into 'cleaning up' mode even after I had deleted the sparsebundle.


    @Tech Harmony I concur, Gb Ethernet is often limited mainly by the hard disks at each end and other factors.  Tom's Hardware did an very good article on it in 2009:


    My Gb Ethernet is completely in line with my iSCSI DroboPro speed at destination and not the Pegasus at source.


    Also should be noted I am getting this even with Lion Server installed for those looking to that as an answer.

  • 373. Re: time machine very slow with mountain lion
    LegalGeek Level 1 Level 1 (0 points)

    So far, I have installed all of the following:


    • MS Office 2011 + Updates
    • 1Password - App Store Version
    • Dropbox
    • Java + Updates
    • Citrix Receiver
    • Kyocera Print Driver
    • Xerox Print Driver
    • Steam Client


    I just completed a TM backup from scratch last night and it worked pefectfly. It took about 7 hours to back up over 500GB of data. Again, speed is not a problem. This morning, I am installing Adobe Production Premium CS6 and maybe some other apps. Tonight I'll run another backup from scratch and see how it goes. Hopefully by doing app installs incrementally with backups overnight, I can help narrow down the offending program.


    It still doesn't discount the possibility that some random leftover kext or other file was causing the problem for me when 10.8.2 was installed. But, at least it is working now even if it was a huge pain in the rear getting to this point.


    Just to clarify some points others have made, I DID try to backup using WiFi and it did not work for me. It still froze after a period of time. The only way I WAS able to back up using TM before was using an external drive conencted directly by USB. This could also point to a networking issue, but if that were the case, it would not be working now.

  • 374. Re: time machine very slow with mountain lion
    HayoBaan Level 1 Level 1 (0 points)

    Interesting, it seems there are multiple problems with Time Machine backups and Mountain Lion. Both (seemingly) related and not related to networking. I'm quite sure none of the problems have anything to do with third party applications though:


    My problems began after a clean install of Mountain Lion (manual migration of user documents and fresh install of applications) on the new SSD of our desktop machine. Suddenly backing up my (then still Lion) laptop over a direct-wired network to the sparsebundle on the desktop machine where taking ages/stalling. Backup over WiFi still worked Ok (slower than before ML, I think though). That the problem is somehow ML related (and not e.g., hardware) was proven by the fact that booting back to my old Lion install on the the same desktop made all problems with time machine disappear… Also, other than TimeMachine having trouble, the direct network connection seems to be working just fine with the same speeds as before.


    I must also note that we have no issues whatsoever using TimeMachine on our desktop to backup to the firewire800 connected drive. This goes fine, as before the ML upgrade. This all to me is a clear indication that there's something wrong at the network layer in Mountain Lion.


    For the record, I have not yet tried disabling the (Mountain Lion) firewall to see if that helps. Has anyone else tried this already and did it help?

1 23 24 25 26 27 Previous Next