Skip navigation

Alternative to Mail Server or nice fix

1269 Views 6 Replies Latest reply: Nov 15, 2012 2:36 AM by niklasfromstockholm RSS
niklasfromstockholm Calculating status...
Currently Being Moderated
Nov 7, 2012 3:06 AM

Hi,

 

I bought a Mac Mini last year and went through the incredibly difficult process of getting the Mail Server to work. Being used to Microsoft Windows servers where I always fetched emails from our ISP, setting up an internet-facing mail server was quite difficult for me.

 

After trying (and failing) with apps like Fetchmail, I finally got it to work by skipping the step of trying to fetch emails and rather do it the real way by directing MX traffic to the server and injecting the Mail Server with emails directly (like any mail server I suppose). I should also add that before I saw the light at the end of the tunnel, I had to speak to Apple's Server support on multiple occasions, as well as re-installing OSX three times.

 

Yesterday, I re-started the server for the first time since configuring everything last year. That was a big mistake. The emails stopped coming in.

 

Instead of trying to fix this mysterious problem (emails simply did not arrive, with no errors or anything) I decided to upgrade to Mountain Lion while I was at it. I thought to myself, "perhaps I'm lucky and this problem will go away". I was not lucky. Not one bit. When I went to Server.app and tried to turn Mail off, it gave me an array of nice looking error messages. To make things more interesting, I can't actually provide said error messages as they have stopped showing up when turning off the service.

 

All I know is this:

 

a) it's not working.

b) it was working until i restarted the service.

c) I have probably made things worse by upgrading to a new OS X without first fixing the source of the problem.

d) when testing the SMTP server (https://www.wormly.com/test_smtp_server), I get this:

 

Resolving hostname...

Connecting... SMTP -> FROM SERVER:

220-server.company.se ESMTP Postfix

SMTP -> FROM SERVER:

220 server.company.se ESMTP Postfix

SMTP -> ERROR: EHLO not accepted from server: 220 server.company.se ESMTP Postfix 

 

SMTP -> FROM SERVER:

250-server.company.se

250-PIPELINING

250-SIZE 10485760

250-VRFY 250-ETRN

250-STARTTLS

250-AUTH DIGEST-MD5

250-ENHANCEDSTATUSCODES

250-8BITMIME

250-DSN

250-BINARYMIME

250 CHUNKING

MAIL FROM: niklas@sender.com

SMTP -> FROM SERVER:

250 server.company.se

RCPT TO: info@company.se

SMTP -> FROM SERVER:

250 2.1.0 Ok

Sending Mail Message Body...

SMTP -> FROM SERVER:

250 2.1.5 Ok

SMTP -> ERROR: DATA command not accepted from server: 250 2.1.5 Ok 


Message sending failed.


Anyone have a clue?

Mac mini, OS X Server, Mountain Lion Server
  • Strontium90 Level 4 Level 4 (2,895 points)
    Currently Being Moderated
    Nov 7, 2012 3:40 PM (in response to niklasfromstockholm)

    While it is irrational to hate software, I truly hate Apple's mail server implementation.  You should look to replace this with Kerio or run a three year cost comparrision to see if hosted mail is affordable.

     

    Now, regarding your issues.  What is being reported in system log?  If you run a:

     

    sudo serveradmin mail stop

    sudo serveradmin mail start

     

    (Or use Server.app assuming it is working)

     

    What are the messages reported in system log?

  • Strontium90 Level 4 Level 4 (2,895 points)
    Currently Being Moderated
    Nov 8, 2012 1:01 PM (in response to niklasfromstockholm)

    I am so sorry.  I inversed the command order. 

     

    It is

     

    sudo serveradmin stop mail

     

    then

     

    sudo serveradmin start mail

     

    I had a dyslectic moment.

  • Strontium90 Level 4 Level 4 (2,895 points)
    Currently Being Moderated
    Nov 12, 2012 5:44 PM (in response to niklasfromstockholm)

    Sorry for delay.  In the hurricane zone and customer coming first.  Let's look at your log to see if it is giving any good info:

     

    Here is where you stop it.

     

     

    PWD=/Users/admin ; USER=root ; COMMAND=/Applications/Server.app/Contents/ServerRoot/usr/sbin/serveradmin stop mail

    Nov  9 09:50:24 server.hega.se serveradmin[77180] <Notice>: malformed plist file: missing keys /Library/Server/Network/Config/autoportmap.plist

    Nov  9 09:50:25 server com.apple.launchd[1] (org.clamav.freshclam[57301]) <Error>: Exited with code: 2

    Nov  9 09:50:33 server.hega.se dovecotd[57299] <Warning>: master: Warning: Killed with signal 15 (by pid=1 uid=0 code=unknown 0)

    Nov  9 09:50:33 server.hega.se log[58045] <Warning>: log: Warning: Killed with signal 15 (by pid=1 uid=0 code=unknown 0)

     

    Note what is happening.  serveradmin complains about a possible malformed plist.  clamav (virus scanner) exits.  dovecotd exits.

     

    Now, look what happens when you restart.

     

    Nov  9 09:51:03 server.hega.se sudo[77191] <Notice>:    admin : TTY=ttys000 ; PWD=/Users/admin ; USER=root ; COMMAND=/Applications/Server.app/Contents/ServerRoot/usr/sbin/serveradmin start mail

    Nov  9 09:51:08 server.hega.se postfix/postfix-script[77901] <Warning>: warning: not owned by _postfix: /Library/Server/Mail/Data/mta/./guid_device_maps.plist

    Nov  9 09:51:08 server.hega.se serveradmin[77192] <Notice>: malformed plist file: missing keys /Library/Server/Network/Config/autoportmap.plist

    Nov  9 09:51:08 server.hega.se serveradmin[77192] <Error>: posting dist not

    Nov  9 09:51:08 server.hega.se dovecotd[77195] <Warning>: master: Warning: SIGHUP received - reloading configuration

    Nov  9 09:51:10 server.hega.se mail_groups[77922] <Error>: sleeping for: 1 hour(s)

    Nov  9 09:51:10 server.hega.se push_notify[77194] <Notice>: Opening connection to apn feedback server feedback.push.apple.com for topic com.apple.mail.XServer.566be605-aaa8-4c3d-98a8-2bda96630367

    Nov  9 09:51:12 server.hega.se push_notify[77194] <Notice>: Disconnected from apn feedback server feedback.push.apple.com for topic com.apple.mail.XServer.566be605-aaa8-4c3d-98a8-2bda96630367

    server:~ admin$

     

    The line:  warning: not owned by _postfix: /Library/Server/Mail/Data/mta/./guid_device_maps.plist may suggest some permissions issue.  You can try doing a repair permissions followed by a reboot.  If you are lucky, this may resolve.  If not, use Terminal to look at the permissions of this file.  Reset if needed to be owned by the _postfix user.  I woudl start there.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.