Skip navigation

Can't join home network after upgrade to iOS 6

37972 Views 145 Replies Latest reply: Feb 27, 2013 6:28 AM by bananagas RSS
  • NabeelaHK Calculating status...

    SAME TO ME!!!
    After I upgraded to IOS6, my wifi is acting up.
    So basically...I can connect to my wifi but it cuts off after 2 mins. I have to disconnect and reconnect to my'll remain connected for 2-5 mins and then it will cut off. This continuously happens. My other devices are functioning normal. Only thing I did different?.. Upgrade to IOS 6.
    I'm using the new IPAD or Ipad 3 btw.
    No issues before the upgrade.
    Can't use this useless device with an amazing screen......

  • Joshua D David Calculating status...

    Hi chaps,


    I did two things to resolve this issue


    1. Downgrade the router to a lower version.If your router is Netgear WGT624 v3 use this link to downgrade your router



    (this help to avoid getting a errro message "Unable to join network")


    2. Reconfigure you Wifi network by going to setting ---->under choose a network---> others-----> Enter your SSID name (seen at the back of your router) ----->under the security tab selet the same encyrption standard as that of your router which you can see when you log in to the router (usually router IP ---->setup ------>wireless setting----> security option. This one helps you to join your home wifi as soon as you enter your home.



    I hope this one works as it worked for me

  • Micp879 Calculating status...

    Dave, SP, et al,


    I tried the work around regarding rolling back to a prior firmware version, and it did the trick. You guys rock! I was beginning to think my new Iphone 5 had a hardware issue, or I was going to need to buy a new router. I have bookmarked this thread so I can check back and see if there is any update on netgear fixing the issue in the latest firmware. Again, thank you guys so much!!



  • TLmix Calculating status...
    Currently Being Moderated
    Oct 9, 2012 2:14 PM (in response to LapGear)

    I have the same problem.   It's been killing me ever since the upgrade.   Please fix this.


    Netgear WG102

    iOS6, iPhone 4s, iPad 2

  • TLmix Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 9, 2012 3:26 PM (in response to TLmix)

    Reverting the WG102 firmware to 5.0.1 fixes the problem.   Netgear support was very helpful.  

  • mbuck1027 Calculating status...

    I'm having the same problem but have an Xfinity cable modem - anyone figure that one out yet?  If i reboot the modem, the connection comes back for a short period of time, but then flips back to 3G and gives me the unable to connect message when I try to reconnect.  Help!

  • CyndyS Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 9, 2012 10:24 PM (in response to mbuck1027)

    WIth all the focus shining on Netgear routers and telling Apple it appears to be a Netgear issue, I hope those of us with these exact issues and using different brands of routers aren't left out.  I hope they fix this issue universally and don't just focus on Netgear routers.


    I rue the day I ever loaded iOS6. 

  • frankfromlothian Calculating status...
    Currently Being Moderated
    Oct 12, 2012 2:13 PM (in response to Snow755)


    Are you saying a full restore made your iPad3 work? Using a Netgear WGT624 v3 router?

  • Ed.MacDonald Calculating status...
    Currently Being Moderated
    Oct 15, 2012 6:54 PM (in response to CyndyS)

    I ran into the exact same issue with my D-Link DIR-601 firmware versions 1.01 and 1.02.


    On my iPhone4 I was getting the "can't connect" message and after reading a post somewhere I tried to "forget" my network after which I would get the "Invalid Password" message.


    What worked for me was connecting manually.  I choose "Other", entered the SSID, choose WPA2, then the password when prompted and it worked.  The manual connect method may bypass the "capabilities" issue by skipping the negotiation.



  • rjb93ch Calculating status...

    Has anyone tried iOS 6.0.1 with the latest firmware on the Netgear WGT624v3 router? Does iOS 6.0.1 fix this?

  • lsofnj Calculating status...

    I just tried ios 6.0.1 and it does not help.  still get the same error unable to join on my netgear wtg624.  Rolling back the version did work for me, but then I realized that I originally upgraded my router since my new lenovo laptop couldn't connect using this older version about 6 months ago.  So since I still had 3g on my iphone, I had to re-upgrade my router so my laptop can connect.  very frustrating... I was hoping this new release would help.

  • Ed.MacDonald Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 12, 2012 7:29 PM (in response to lsofnj)

    If you manually select the auth type per my instructions above, you should not have a problem.



  • lsofnj Level 1 Level 1 (0 points)

    Just tried Ed's suggestion and I still get the same error message.  In addition, I disabled security on the router so a password wasn't required and still couldn't get on when manually connecting to my home network.  I am able to connect to other hotspots and routers when I am out, so my problem seems to be isolated to the Netgear WGT624v3.

  • Ashedan Calculating status...

    Upgraded iphone 4S to ios6.  Using an Airport Extreme for wifi network.  My phone connects just fine to network but won't connect through it to internet.  I can get to internet through other networks but not my Extreme one.  I know the extreme is connected to the internet because my iMac does just fine.

  • johnfromdelaware Calculating status...

    I have a new iPad mini (updated to iOS 6.0.1) and after about 4 days it suddenly refused to connect to my home WiFi network (AirPort Extreme base station). All other wireless devices worked fine.  


    I did all the recommended resets, restarts, and on and on.  No dice.  Then I did a routine app update (via iTunes/USB from my Mac), nothing out of the ordinary, and WiFi was fine after that.  I'm thinking there might be a "bad app" that might have caused the problem, because there were no other changes.  Upgraded 22 apps, so I'm not sure what the culprit might have been.  Just a thought.

1 ... 6 7 8 9 10 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (10)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.