Skip navigation

Help!!! Ipod stuck in recovery mode!!

14216 Views 6 Replies Latest reply: Dec 5, 2012 10:26 AM by lllaass RSS
J.awesome Calculating status...
Currently Being Moderated
Nov 7, 2012 8:26 PM

My IPod touch (4th generation 8G) is stuck in recovery mode. When I try to restore it ITunes says that an error (1604) has occurred. I have tried switching USB ports and using different cables but nothing works!! And sometimes ITunes doesn't even recognise that my IPod is plugged in, I know it is because my computer makes the noise that means something is plugged in!! Please help!!!

iPod touch (4th generation)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.