Skip navigation

Phone still shows up as iMessage after buying android phone

1615 Views 4 Replies Latest reply: Nov 13, 2012 9:29 PM by D75 RSS
trakmasters Level 1 Level 1 (0 points)
Currently Being Moderated
Nov 12, 2012 10:05 PM

My father had a iPhone 4s, and he decided to purchase the new Samsung galaxy note 2. Every time I try to send him a text on my iPhone 4s, it still tries to send him an iMessage. How can I fix this?  When I disable iMessage on my phone, I can send him a text, but as soon as I turn it back on, itvreverts back to sending him a imessage. I also tried to delete his contact from my address book and restarted my phone and it still does it. I also want to inform y'all that I'm using exchange server for my address book. Can someone please help. He also mentioned that he Vthinks others with iPhones have texted him with no issues.

iPhone 4S, iOS 5.1
  • sberman Level 7 Level 7 (23,700 points)

    When you compose this message to your father, and send it, it should be sent as a text message.  Have you tried to send it, or are you discouraged by seeing "iMessage" while you're composing it?

     

    Even iPhones may be out of WiFi (or cellular coverage allowed by iMessage) range when you send them what would otherwise be an iMessage.

     

    If the message is blue when sent, it is an iMessage.  If green or white, it is not.

  • wjosten Level 10 Level 10 (91,360 points)

    Your father should have turned off iMessage BEFORE getting rid of the 4S. He can fix this by putting his sim in any iPhone & turning iMessage off, or by logging into his Apple support profile & removing the 4S...assuming he setup a support profile with Apple. If not, he'll have to do the sim in another iPhone deal to fix.

  • D75 Calculating status...

    I had the same exact problem as your father and as another post mentioned, I also used my new sim to disable iMessage with success. I love apple products and praised my iPhone but I was thoroughly disappointed by the new iPhone so I purchased a samsung Galaxy S3. I love the phone and was enjoying all of its features, except for the text issue exactly as you described. Nobody at AT&T told me that this would be an issue so I didn't know to deactive iMessage before setting up the new phone.

     

    Long story short, I turned off the samsung, put my sim into my old iPhone and turned the iPhone on. I was hammered by tons of iMessages that were queued while the phone was off. I Immediately went into settings >> SMS >> disable iMessage toggle. I turned everything off and put the sim back into my droid and turned it back on. People that could not text me before were suddenly having their messages come through to my droid now. I also tried to go into my Apple support profile afterwards just to see what it was all about but my iPhone 4 was not listed so I'm not sure if there's any correlation to the support profile and the iMessage. I don't know for for sure but I suspect that it may just be like an old wives tale. Anyway, the problem was resolved by simply putting in the old sim and turning off iMessage, then turning off the phone and swapping the sim back. If you're on verizon by chance, I'm not sure. Good luck.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.