1 2 Previous Next 17 Replies Latest reply: Jun 6, 2014 8:58 PM by hausjam
ZaYoOoD Level 1 Level 1 (0 points)

My Magic Mouse lags when I use Windows 8 on bootcamp on my 2012 Mac Mini..

It is really bothering! I can barely use it..

 

However, when I use my bootcamp Windows 8 using a virtual machine on Mac (i.e. VMware Fusion 5), the mouse works just fine..

 

Any fixes or thoughts?


Mac mini, OS X Mountain Lion (10.8.2)
  • 1. Re: Magic Mouse lags in Windows 8 bootcamp
    BobTheFisherman Level 6 Level 6 (10,970 points)

    There are no Windows 8 Bootcamp drivers. Windows 8 is not supported by Bootcamp.

     

    It works in a virtual machine because Windows 8 is using virtual hardware not your computer's real hardware. Therefore no drivers are needed other than the virtual drivers used by the virtual machine.

  • 2. Re: Magic Mouse lags in Windows 8 bootcamp
    ZaYoOoD Level 1 Level 1 (0 points)

    I actually installed Windows 8 using bootcamp assistant, as it says that bootcamp supports Windows 8..
    I then installed the included drivers and software, and everything works just fine, including the trackpad and keyboard. The only thing that has an issue is the Magic Mouse, is there a fix for that?

  • 3. Re: Magic Mouse lags in Windows 8 bootcamp
    BobTheFisherman Level 6 Level 6 (10,970 points)

    ZaYoOoD wrote:

     

    I actually installed Windows 8 using bootcamp assistant, as it says that bootcamp supports Windows 8..
    I then installed the included drivers and software, and everything works just fine, including the trackpad and keyboard. The only thing that has an issue is the Magic Mouse, is there a fix for that?

    Where does it say "bootcamp supports Windows 8"?

  • 4. Re: Magic Mouse lags in Windows 8 bootcamp
    Csound1 Level 8 Level 8 (35,310 points)

    ZaYoOoD wrote:

     

    I actually installed Windows 8 using bootcamp assistant, as it says that bootcamp supports Windows 8..
    I then installed the included drivers and software, and everything works just fine, including the trackpad and keyboard. The only thing that has an issue is the Magic Mouse, is there a fix for that?

    Win 8 is not supported, so there are no official Win 8 drivers yet.

  • 5. Re: Magic Mouse lags in Windows 8 bootcamp
    ZaYoOoD Level 1 Level 1 (0 points)

    Ok..

    Since you claim that Windows 8 is not supported, I removed it and installed Windows 7 "which of course is supported, I use it with my MacBook Air", the problem still presists..

     

    any thoughts?

  • 6. Re: Magic Mouse lags in Windows 8 bootcamp
    Csound1 Level 8 Level 8 (35,310 points)

    Same thought, Apple have not released Windows 8 drivers yet, Windows 7 is supported and in use by many, it works so check your installation.

  • 7. Re: Magic Mouse lags in Windows 8 bootcamp
    Stefan Vasiljevic Level 1 Level 1 (0 points)

    Same here :/

  • 8. Re: Magic Mouse lags in Windows 8 bootcamp
    Ziggyh Level 1 Level 1 (0 points)

    I'm having the same problem on Mac Mini running Windows 8 64bit with latest bootcamp software, which DOES support Windows 8 64bit.  The mouse works then you click something and it freezes for a few seconds (like 10) and then comes back.. thought it was my batteries, but it's not... weird ...

     

    Just as I was typing this I found a solution I believe is working on another site :

    Laggy Magic Mouse on Boot Camp Windows

    I got my new MacBook Pro retina notebook and installed Windows 7 into my boot camp. After installing Windows 8, I installed WindowsSupport drivers that Apple provided me while creating my Boot Camp. However when I connected my magic mouse to my Windows, the problem is that It was a little bit laggy as I track or scroll on the screen. I have spent for 6 hours to resolve this problem but I could not able to find any solution. The problem was actually not about Apple’s Bluetooth drivers but Wireless adapter. I have realized that Wireless adapter was somehow reducing the performance of Bluetooth. The solution is to force Wireless Adapter to collaborate with Bluetooth. When you install drivers Bluetooth Collaboration property of Wireless Adapter comes disabled by default. In order to enable this:

    1- Go to Device Manager >> Network Adapters >> Broadcom 802.11 n and right click and choose properties.
    2- Choose Advanced Tab.
    3- Locate Bluetooth Collaboration from the list. And make it Enable.

    Now restart your computer and enjoy using your magic mouse / trackpad without any freeze or lag

     

    SOLUTION FOUND

  • 9. Re: Magic Mouse lags in Windows 8 bootcamp
    Stefan Vasiljevic Level 1 Level 1 (0 points)

    I have solved the problem! This is what helped me. I am running Windows 8 on MacBook Retina that is connected to thunderbolt display.

     

    Follow these steps:

    1. Go to device manager

    2. Under category network adapters right click the broadcom 802.11n network adapter

    3. Choose properties.

    4. Click on the Advanced tab

    5. Under property list, find Bluetooth collaboration.

    6. In the value field, that is to the right of the property list, selected Enable.

    7. Press OK and close the device manager.

     

     

    That is it. I hope it helps you guys.

     

    Note: restart may be required.

  • 10. Re: Magic Mouse lags in Windows 8 bootcamp
    munzab Level 1 Level 1 (0 points)

    incredible, this worked. i was getting so annoyed with this thing. well done!

  • 11. Re: Magic Mouse lags in Windows 8 bootcamp
    ITCE Level 1 Level 1 (10 points)

    I went in all the way to the Advanced tab and there is no option for Bluetooth Collaboration. I'm bummin'. 

  • 12. Re: Magic Mouse lags in Windows 8 bootcamp
    morgan_0909 Level 1 Level 1 (0 points)

    hello !!!   it really helps...  thanks a lot ...

  • 13. Re: Magic Mouse lags in Windows 8 bootcamp
    Kaske Level 1 Level 1 (0 points)

    Man, you extended my life for like 5 years by solving this. Many thanks!

  • 14. Re: Magic Mouse lags in Windows 8 bootcamp
    Shane226 Level 1 Level 1 (0 points)

    THANK YOU SO MUCH!!!

     

    That was driving me nuts! You are the bomb!

1 2 Previous Next