4 Replies Latest reply: Nov 21, 2012 9:12 AM by mjf12
mjf12 Level 1 Level 1 (0 points)

I have been making dvd's using idvd for some years and have had few problems. Current version is 7.1.2  When I have done so, if I add a title or any comments to a photograph they appear in a 'shadow box' and if I do not no 'shadow box' has appeared on the screen, as you would expect.

However, on my latest dvd some of my photographs have retained a 'shadow box' even though I have not added titles. More interestingly (or not!) it would seem that this only occurs on photographs taken on a particular camera i.e. a Canon IXUS 310 HS, and not on those taken on my other camera a Panasonic Lumix TZ10? Have tried different 'Themes' to see if this makes any difference but apparently not.

Having now spent some time trying to solve the problem from both ends (idvd and camera) am now totally frustrated so grateful for any help


iMac, OS X Mountain Lion (10.8.2)
  • 1. Re: How do I get rid of shadow Title boxes in idvd
    Old Toad Level 10 Level 10 (115,670 points)

    What do you see in the title shadow box for the Canon photos?  Is there any entry?  If so is it the Title or Description that's being displayed, large or small text?

     

    iDVDtitledescription.PNG

     

    Does anything change if you turn on the titles and descriptions and then turn it off again?

     

    If you check the description field in iPhoto for those photos is there any entry in them?

     

    You can try this basic troubleshooting fix:

     

    1 - delete the IDVD preference file, com.apple.iDVD.plist, that resides in your

         User/Home/Library/ Preferences folder.

     

    2 - delete IDVD'S cache file, Cache.db, that is located in your

         User/Home/Library/Caches/com.apple.iDVD folder. 

     

    home.PNG

     

    3 - launch IDVD and try again.

     

     

    OT

  • 2. Re: How do I get rid of shadow Title boxes in idvd
    mjf12 Level 1 Level 1 (0 points)

    Many thanks for getting back to me. As regards your questions/proposals:

     

    • Where I have inserted comments in the title shadow box for the Canon photos it is displayed as per your Bernese Alps example above. Where I have not inserted comments only a shadow title box is displayed (there is no shadow description box - I have not inserted any comments in description boxes)
    • On a possible related issue, I note that when I am looking at all the photos in individual slide shows the Canon photos that I have not included title comments in display only the a 'Add title' option, whereas the Panasonic pictures with no comments in display both 'Add title' and 'Add comments' options?
    • I have tried turning titles/descriptions on and off in both the dvd settings and idvd preferences, but to no effect
    • When I go to 'Get info' for the Canon photos in iphoto there is no description
    • I have moved the files you list above to trash (but not deleted them entirely as yet) and relaunched idvd but the shadow boxes remain. Should I delete entirely?
  • 3. Re: How do I get rid of shadow Title boxes in idvd
    Old Toad Level 10 Level 10 (115,670 points)

    Go ahead and delete as they were recreated when you launched iDVD.  Just be sure to reset iDVD's preferences to what you need for the project.

     

    Check the contents of the Description field in iPhoto to make sure there's no space added to those Canon photos. Click in the field in about the middle and see if the cursor ends up at the far left.  Hit delete just in case and add it again to the iDVD project and try it out.  A space in the description box will trigger the text box in iDVD. Got to be how Canon creates that field in the file.

     

    Try this test:  log into another user account on your Mac, create an iDVD project, add some of those Canon photos and see if the problem is still there.  If so it's a system wide issue  If not then it's something in your account that's the culprit. 

     

    Another test:  open one of the photos in Preview and save as a new jpeg file.  Try the new file in iDVD. 

  • 4. Re: How do I get rid of shadow Title boxes in idvd
    mjf12 Level 1 Level 1 (0 points)

    Many thanks! When I first looked into the 'description' box for the Canon photos in iPhoto it looked like there was nothing there. However, when I looked again as suggested I realised that the field was not labelled 'description' but 'photo place' and when I went into the field itself each photo had a 'block of nothing' inserted - when I deleted it the label reverted to 'description' and all was well when I used them in iDVD. I have now undertaken the painful process of correcting the above for all the photos used. No idea why Canon does this but will probably be taking many more photos with the Panasonic camera in future!!