Skip navigation

Slow File Transfer over Gbit LAN

2488 Views 6 Replies Latest reply: Nov 15, 2012 1:36 PM by BDAqua RSS
Steffen4712 Calculating status...
Currently Being Moderated
Nov 11, 2012 5:09 AM

- I have a NAS (WD MyBookLive) and want to use it for filesharing and TimeMachine backup.

- Basic configuration is setup and works

 

Problem:

- Transfer of large files from Mac to NAS is unbearably slow, <10 KB/second

 

Setup:

- iMac Late 2009 with 10.8.2

- Gigabit Ethernet Switch

- WD MyBook Live NAS

 

Tried so far:

- replaced cable

- used other computer (Windows) to transfer files to NAS via same Switch, speed is >2 MB/second

- tried to change network protocols to SMB and CIFS - no change

- did the following changes to tcp config:

sudo bash -c "echo 'net.inet.tcp.delayed_ack=0' >> /etc/sysctl.conf"

sudo bash -c "echo 'net.inet.tcp.recvspace=40960' >> /etc/sysctl.conf"

sudo bash -c "echo 'net.inet.tcp.rfc1323=0' >> /etc/sysctl.conf"

 

Observed behavior:

E.g. I try to copy an iPhoto Library of close to 50 GB

- the first 10MB get transferred almost instantly. Then it slows down. A minute later speed is back and it goes quickly to a 190MB transferred. Then it slows down again and speed does not seem to come back. Estimated transfer time is 4 days, and increasing...

- I check system activity. Network and HD activity is low

TimeMachine also seems very slow in preparing the backup and transferring data

 

Any ideas are greatly appreciated.

 

Thanks,

Steffen

 


iMac, OS X Mountain Lion (10.8.2)
  • BDAqua Level 10 Level 10 (114,670 points)
    Currently Being Moderated
    Nov 11, 2012 12:32 PM (in response to Steffen4712)

    Hi Steffen,

     

    Open Network Utility in Applications>Utilities>Info tab, select Ethernet & what is the Link Speed & are there any Errors/Collisions on the right?

     

    Open Console in Utilities & see if there are any clues or repeating messages when this happens.

  • BDAqua Level 10 Level 10 (114,670 points)
    Currently Being Moderated
    Nov 11, 2012 12:33 PM (in response to Steffen4712)

    Oh, what format is he NAS?

  • BDAqua Level 10 Level 10 (114,670 points)
    Currently Being Moderated
    Nov 13, 2012 1:11 PM (in response to Steffen4712)

    Hmmm,

     

    The .apalbum stores photo album, created in Apple Aperture.

     

    apdetected seems something to do with iPhoto.

     

    The NAS is likely FAT32 or NTFS, SMB is a bit broken in 10.7 & up, no idea if yjis would help or if it applies to 10.8.x, but...

     

    SMBUp

    Did you lose your shared folders with the update of Mac OS X from Snow Leopard to Lion? You can’t see your shared folders from your DVR or Medicaneter boxes hooked up to your TV? The internet tells you to install gigabytes of developer tools and use tons of command-line instructions to regain the ability to see your mac from your other devices in the house after moving to Lion? We might be able to help.

     

    http://eduo.info/apps/smbup

  • BDAqua Level 10 Level 10 (114,670 points)
    Currently Being Moderated
    Nov 15, 2012 1:36 PM (in response to Steffen4712)

    Good work & good idea!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.