Skip navigation

installation error xcode 4.2.1 on macmini 1.1

334 Views 1 Reply Latest reply: Nov 13, 2012 11:33 AM by Mark Szymczyk RSS
 born2run67 Calculating status...
Currently Being Moderated
Nov 13, 2012 8:26 AM

Hi all,

 

Hope somebody here can help me with the following issue.

 

I was trying to install xcode on a macmini c2d with lion 10.7.

I have try xcode 4.5.2  but was not possible.

4.3.3 not possible.

 

Then I have tried with 4.2.1, Build 4D502 and the installation was succesful.

But when I hit the Open New Project button, it crashes with an Internal error

 

This is the message I got in the showing details dialog

 

UNCAUGHT EXCEPTION (NSInvalidArgumentException): -[IDECustomToolbar setFullScreenAccessoryView:]: unrecognized selector sent to instance 0x4016ee360

UserInfo: (null)

Hints: None

Backtrace:

  0  0x00007fff947e0e4a __exceptionPreprocess (in CoreFoundation)

  1  0x00007fff96526dca objc_exception_throw (in libobjc.A.dylib)

  2  0x00007fff9485c725 -[NSObject doesNotRecognizeSelector:] (in CoreFoundation)

  3  0x00007fff947b2b33 ___forwarding___ (in CoreFoundation)

  4  0x00007fff947af3e8 _CF_forwarding_prep_0 (in CoreFoundation)

  5  0x000000011030a10e -[IDEWorkspaceWindowController windowDidLoad] (in IDEKit)

  6  0x00007fff980d77c2 -[NSWindowController _windowDidLoad] (in AppKit)

  7  0x00007fff9807618e -[NSWindowController window] (in AppKit)

  8  0x000000011051b6c8 -[IDEDocumentController _openUntitledWorkspaceDocumentAndDisplay:simpleFilesFocused:editorDocumentURLOr Nil:error:] (in IDEKit)

  9  0x0000000110400d4f -[IDEApplicationCommands showTemplateChooserForTemplateKind:] (in IDEKit)

10  0x00007fff9485b6ad -[NSObject performSelector:withObject:] (in CoreFoundation)

11  0x00000001103f84b8 -[IDEApplicationController(IDECommandAdditions) forwardInvocation:] (in IDEKit)

12  0x00007fff947b2cb4 ___forwarding___ (in CoreFoundation)

13  0x00007fff947af3e8 _CF_forwarding_prep_0 (in CoreFoundation)

14  0x00007fff9485b6ad -[NSObject performSelector:withObject:] (in CoreFoundation)

15  0x00007fff981dbd00 -[NSApplication sendAction:to:from:] (in AppKit)

16  0x000000010fc1ed10 -[DVTApplication sendAction:to:from:] (in DVTKit)

17  0x0000000110306cf4 -[IDEApplication sendAction:to:from:] (in IDEKit)

18  0x00000001103fb0f5 +[IDECommandManager sendActionForCommandWithIdentifier:from:] (in IDEKit)

19  0x00007fff9485b6ad -[NSObject performSelector:withObject:] (in CoreFoundation)

20  0x00007fff981dbd00 -[NSApplication sendAction:to:from:] (in AppKit)

21  0x000000010fc1ed10 -[DVTApplication sendAction:to:from:] (in DVTKit)

22  0x0000000110306cf4 -[IDEApplication sendAction:to:from:] (in IDEKit)

23  0x00007fff981dbc32 -[NSControl sendAction:to:] (in AppKit)

24  0x00007fff98261a4e -[NSCell _sendActionFrom:] (in AppKit)

25  0x00007fff98261355 -[NSCell trackMouse:inRect:ofView:untilMouseUp:] (in AppKit)

26  0x00007fff9829013a -[NSButtonCell trackMouse:inRect:ofView:untilMouseUp:] (in AppKit)

27  0x00007fff9825fe7b -[NSControl mouseDown:] (in AppKit)

28  0x00007fff981863fc -[NSWindow sendEvent:] (in AppKit)

29  0x00007fff980bd4a6 -[NSApplication sendEvent:] (in AppKit)

30  0x0000000110306a11 -[IDEApplication sendEvent:] (in IDEKit)

31  0x00007fff98055593 -[NSApplication run] (in AppKit)

32  0x00007fff9804e33d NSApplicationMain (in AppKit)

33  0x000000010fa00eec (in Xcode)

34  0x0000000000000002

 

can anyone help me out

thanks in advance

alfredo

Mac mini, Mac OS X (10.7)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.