13 Replies Latest reply: Nov 20, 2012 10:49 AM by BetoMenegocci
GatoV Level 1 (0 points)

I installed Mountain Lion on Mac Book Pro, I have the latest Iphoto and latest Aperture(3).  I only use Aperture, but for some reason it will not open, it asks me to upgrade library first with Iphoto 9.3.  I then went in to Iphoto 9.3, and it says that library is in use by another application.  I tried repairing the library by using the "command" "option" on both programs, but I get the same results.  I have no back up and I ran out of ideas, someone please help!

  • léonie Level 10 (90,876 points)

    Aperture may be trying to open a wrong library. Quit iPhoto, if it still should be open. Log off and log on again, to be sure that no application is still holding the libraries.


    Then select your Aperture library directly in the Finder and try to open it by double clicking the Library.


    I then went in to Iphoto 9.3, and it says that library is in use by another application.

    This may happen, if the Aperture Process is still running, even if you quit the application.


    I have no back up and I ran out of ideas, someone please help!

    Then now would be the time to make a backup


    When you have finished the backup, and Aperture still will not launch on your library, rebuild the library by double clicking your Aperture library.


    Post back, if this does not help.




  • GatoV Level 1 (0 points)

    Thanks but no Cigar.


    after clicking the library from Finder, I get the same message "To Open this Iphoto library in Aperture, it first needs to be upgraded".  I then close everything and start with Iphoto and when I try to use the library I get, "Your photo Library is either in use by another application or has become unreadable".  When I try to repair the database in either program, I get the respective messages from above. 


    I did backup the current library in another hard drive just in case.



  • léonie Level 10 (90,876 points)

    https://discussions.apple.com/servlet/JiveServlet/showImage/2-19338851-148317/aplib.pnghttps://discussions.apple.com/servlet/JiveServlet/showImage/2-19338851-148317/aplib.png https://discussions.apple.com/servlet/JiveServlet/showImage/2-19338851-148462/photolib.png


    When you select your Aperture library in the Finder, what do you see? Does the "Kind" show as "Aperture Library" and the version is 3.3.2, like on the left, or is the "Kind" "Photo Library" and the version 9.3.2, or do you see something else?


    If  you are sure, that the Library has been created by Aperture, ctrl-click it and select "Open with" from the pop-up menu, then select Aperture in the Applications folder to open the library.

  • GatoV Level 1 (0 points)

    In kind it says "Aperture Library", but in does not have the "Version" Label".


  • léonie Level 10 (90,876 points)

    Try to remove the Aperture Preferences as described in
    Aperture 3: Troubleshooting Basics:


    If it does not help, check the permisissions on your Aperture Library in the "Get Info" panel. Add Read&Write for yourself and apply to enclosed items, if necessary.

  • GatoV Level 1 (0 points)

    I give up.  nothing worked.  I, however, found a way to see the pictures and will have to consolidate them one by one and import them back to Aperture, what a long weekend this will be!


    A million thanks for your help and persistence.

  • Frank Caggiano Level 7 (25,722 points)

    One thing to try if you go to the library in the finder, right click it and select Show Package Contents you will see a file called iPhotoLock.data. Delete it and try opening it again.

  • GatoV Level 1 (0 points)



    re-installed from previous versions, upgraded everything again and clicked on the file that would not open and WHAM! it upgraded the library with everything back to normal.  What a rough couple of weeks!


    Thanks everyone for your support

  • BetoMenegocci Level 1 (0 points)

    Hi GatoV,


    I'm having the same problem as you, and nothing seems to work. Could you post a step-by-step on how you got this to work? I have tons on my wedding/engagement pictures that are, at the moment, in limbo because of this!



  • Aye Es Oh Level 2 (330 points)

    Beto, try the steps here in the Aperture 3 Basic Troubleshooting document and see if any of those steps help. Near the bottom of the document are the reinstallation instructions, you can try those first, but I'd suggest trying to repair or rebuild as well if you haven't already. Let us know if you have any success.

  • GatoV Level 1 (0 points)

    Hello there,

    what I did was copy the Aperture library to another directory and reinstall Aperture completely.  Then I just clicked on the aperture library file and it automatically upgraded the library to the new Aperture version and that is all it took.


  • joeholmes Level 1 (0 points)

    Thanks. My Aperture Library package doesn't seem to have any iPhotoLock.data file in it...

  • BetoMenegocci Level 1 (0 points)

    I finally was able to recover the library! I reinstalled Aperture, and tried to open the Aperture library I had moved to a different directory. It gave me the same message I was getting before. I then opened the package (right-click, "see package contents"), opened iMovie thumbnails, and other folders, which let me to another Aperture Library. By double-clicking that, Aperture prompted me to update it, and everything is running normally now!


    Thanks for the help!