Skip navigation

Samsung SCX-4623 Scanner failed to open

138 Views 0 Replies Latest reply: Nov 13, 2012 4:22 PM by Toreshii RSS
Toreshii Calculating status...
Currently Being Moderated
Nov 13, 2012 4:22 PM

Hi everyone, I would really appreciate it if anyone can offer some insight into this problem. My scanner recently stopped working. I have a Samsung 3-in-1 printer (SCX-4623) that prints from my imac, but doesn't scan through any program. I've tried Image Capture and opening the scanner through System Preference. I've also tried updating all the software and drivers relevant to the printer, and tried to uninstall the printer and reinstall again. I've also tried calling Samsung (4 times!) and they were definitely not helpful. (Don't worry, I'm writing a letter of complaint about their customer service.) It's definitely not a hardware issue, as it prints and scans on my laptop running Windows 7. I believe it's one of the updates. Please give me some advice! Thank you!

iMac, Mac OS X (10.7.5)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.