Skip navigation

Reposting - "Incoming Mail Server" field cannot be empty

337 Views 3 Replies Latest reply: Nov 25, 2012 7:34 PM by Emily Kessler RSS
Emily Kessler Level 1 Level 1 (35 points)
Currently Being Moderated
Nov 13, 2012 8:36 PM

[Reposting in more appropriate discussion area]


I changed my iCloud password today and then tried to update password settings on my MacBook Air in System Preferences and Mail.  I first started in System Preferences/iCloud.  I signed out and then signed back in with new password.  Everything updated except Mail, which prompted me to update settings in the Mail application.  When I launched Mail, my iCloud account was missing, so I created a new iCloud account in Preferences. This is where the trouble began.  I was able to successfully create the account, but when I tried to make any changes to the default setting (i.e. changing Junk mail filtering in Mailbox Behaviors), I was prompted to save my changes (as normal), BUT then I received this error message:

 

Invalid Incoming Mail Server.

The "Incoming Mail Server" field cannot be empty.

[OK]

 

The only option was to click OK and then lose the changes.  I tried deleting the account and starting over.  I tried restarting the laptop.  I tried signing back out of iCloud in System Preferences.  Nothing has worked.  I'd like to make changes to the account settings and not get stuck with the default settings.  Incidentally, when I looked up this issue in previous discussions, I tried the other recommendations that seemed to work for everyone else, but hasn't worked for me.

 

FYI, I'm running the most recent version of Mountain Lion.

 

If anyone has any other suggestions, I'd love some help with this.

 

Thanks!

 

P.S. Why does Apple make everything so hard when you need to change a password?  This has cost me hours of time, not to mention my sanity.

P.P.S.  I've had no issues in updating my iPhone and iPad.

MacBook Air (11-inch, Mid 2012), OS X Mountain Lion (10.8.2)
  • BigBumpinChicken Calculating status...

    Hi Emily -

     

    I ran into this problem this morning also. I am trying to change the name of the account from "iCloud" to "Nancy's iCloud",  like I have already done with my other iCloud account.  I am working on it,  will let you know when I find out.  Definitely a bug.

  • BigBumpinChicken Level 1 Level 1 (0 points)

    Hi Emily -

     

    I figured out my issue, it was a little tricky.  I had to re-enter the password in the Mail->Mail Preferences window for the account I was trying to change (we have two iCloud accounts). The window showed a password filled in already (the little dots),  but apparently it is not the real password.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.