6 Replies Latest reply: Nov 13, 2012 11:15 PM by agj3.1
giuliofrommilano Level 1 Level 1 (0 points)

Dear all, after I updated my iPhone and iPad to iOS6 I have an issue with accessing my home wifi network.

I have pay-per-use ISP, thus I have to login on their captive portal to access the Internet.

I don't need to login (and pay) every time I connect to my wifi, since I have a number of personal devices connected on my home network, both wired and wireless.

Now when I connect to my wifi router iOS 6 shows the ISP captive portal. If I chose "cancel", iOS also drops the connection to the router!

 

Currently I can't connect to *my* NAS, without logging to my ISP network and pay!!

 

Any tips on how to disable this annoying automatic login page?


iPad 2 Wi-Fi + 3G, iOS 6
  • 1. Re: disabling captive portal login in iOS 6
    paulrayjace Level 1 Level 1 (10 points)

    Hi, just came across the below workaround in another thread that works for me. Apple need to fix this asap, but at least this workaround may help in the mean time:

     

    1. Settings>>Safari>>"Clear History" also "Clear Cookies and Data" (not sure if this step is actually required or not)

     

    2. Turn Your Cellular Data Off

        Settings>>General>>Cellular>>Cellular Data (OFF)

     

    3. Connect to your desired Wifi network

         Settings>>Wi-Fi>>(Your Network Name)>>HTTP Proxy(Auto) + Leave URL empty

     

    Login screen should pop-up, but now it should direct you to your usual authentication page.

     

    4. Turn Your Cellular Data back on (just to get you back where you started)

        Settings>>General>>Cellular>>Cellular Data (On)

     

    Hope that works for you too.

  • 2. Re: disabling captive portal login in iOS 6
    Videogreg Level 1 Level 1 (10 points)

    I run a number of wifi hotspots, all of which use a captive portal "Splash Page" that is branded per location.

     

    Since the iOS6 update I have been swamped with guests and customers complaining about this www.apple.com "success" page popping up instead of the intended customers login and terms acceptance page. When cancelling it drops the wifi router connection and there is no way to connect to the intended free wifi hotspot.

     

    The problem is in Apple's update, there currently is no way to disable this unwanted feature.

     

    The solution is to go to your Settings>General>Cellular>Cellular Data and turn it OFF when you are at the hotspot location.

     

    Now when you choose the hotspot's SSID and join it......you will get the sign in page from the captive portal and not the "success" page.

     

    Be sure and turn the Cellular Data back on.....when you leave the hotspot.

     

    Apple needs to fix this WISPr function, I am only a small provider and I am sure that worldwide there are going to be hundreds of thousands of iphone, ipad and laptop users who will no longer be able to sign on at wifi hotspots, work, universities, hospitals and hotels.

     

    As a side note: I have an older 4S phone with iOS6 and I cannot join.....my wife has a newer 4S phone with iOS6 installed and even though both our phones are set exactly the same......she can connect without turning off her cellular data and I cannot.   Curious?

  • 3. Re: disabling captive portal login in iOS 6
    giuliofrommilano Level 1 Level 1 (0 points)

    Oh, my Gosh!

    Thanks to your tips now I can connect to my local wifi without receiving the splash page from my ISP.

    BUT

    now I never get it! even when I write an external URL in Safari!

    Safari hangs and efter some seconds says that "the server has stopped answering".

     

    Now I'm in the thousends that populate the other thread "iOS 6 wifi issue"!! :-(

    In 90 pages I've seen no real solution

     

    May the soul of Steve forgive those sinners!

     

    GF

  • 4. Re: disabling captive portal login in iOS 6
    u.porcheddu Level 1 Level 1 (0 points)

    How can we develop something smart when apple keeps managing its customers as idiots?

  • 5. Re: disabling captive portal login in iOS 6
    @raj Level 1 Level 1 (0 points)

    Hi do suggest a solution

     

    When connected to the wifi, the log in page comes

     

    After entering the username and password,

     

    It says

     

    FAiled to open the sonic wall user status window

    To get access u need to ensure that pop ups are not blocked for 192.168.2.1

     

    I couldn't enable this pop up even though the pop up setting is switched off