7 Replies Latest reply: Nov 14, 2012 8:50 AM by walterholt
walterholt Level 1 Level 1 (45 points)

My Epson StylusC120 ink jet printer is connected by USB cable directly to my Power Mac G5 running Leopard 10.5.8.  It prints fine.

 

I have a Belkin 54g router connected to my cable modem so my Wife's Macbook running Snow Leopard 10.6.8 can use the internet and my printer.

 

Their was never any problem wth the Macbook (Snow Leopard) using the printer when I was running Tiger 10.4.11 on my PowerMac G5.

 

However, since I upgraded my Power Mac G5 to Leopard, the Mac Book cannot make the printer print.

 

If the Macbook's que window is opened it reads "Printer Ready".  If a document is requested to be printed by the MacBook, the Macbooks que instantly changes to  "Printer Paused".    If "Resume Printer" is clicked it instantly jumps back to Pause. Deleting the job from the que allows the Printer Ready to remain on.

 

Sometimes for an instant the Macbook's que window reads "Printing" but then pauses the printer.  On rare occassion the message "Searching for Printer"

will flash for an instant.

 

I opened up the "Job Info" window in the MacBooks's que window box and the last line of the job info reads as follows.....  Job Message: /usr / libexec / cups / backend / dnssd failed.     Does this give anyone a clue as to my problem?

 

I have checked and rechecked System Prefs setting on both Macs in the Print & Fax Prefs section and the Sharing Prefs section to make certain sharing was on in both Macs.

 

In the Options Windows in the Print&Fax prefs for both Macs the printer names are the same and the spellings are correct. The drivers are the same version too.     

 

However the URL is NOT the same for both macs in their Options Windows.    The Macbook's URL starts out  dnssd:// EPSON and then a string of % signs and names ending with  _ipp._tcp.local.       The URL in my Power Mac to which the printer is connected is shorter and reads usb://EPSON/Stylus%20C120?serial= and a long serial number.

 

I know  little about computers, but I feel the answer to my problem lies in the fact the the Job message in the Macbook's Job info window reads

/usr / libexec / cups / backend / dnssd failed. and the URL in the Macbook starts with these same letters dnssd.

 

Any help will be appreciated.

 

Walter


MacBook, Mac OS X (10.6.8)
  • 1. Re: Printer jumps to pause whenever Macbook tries to print
    ShlomiL Level 3 Level 3 (675 points)

    Hi,

    It seems as teh Mac fails transferring Multicasting packets correctly, it may happen due to lack of Multicast support or wrong configuration of the router.

     

    Try setting the printer using Jetdirect and check if  that may help:

    • Open Print & Fax.
    • Click the Plus icon.
    • Click the IP Tab.
    • Set the Protocol as HP Jetdirect-Socket.
    • Type the printer IP address into the address field.
    • Click Add to complete adding the printer and try printing using the newly created queue.

    Shlomi

  • 2. Re: Printer jumps to pause whenever Macbook tries to print
    walterholt Level 1 Level 1 (45 points)

    ShlomiL,

     

    But I am using an Epson Stylus C120 printer not an HP printer.

  • 3. Re: Printer jumps to pause whenever Macbook tries to print
    ShlomiL Level 3 Level 3 (675 points)

    This is the Jetdirect protocol name within the OS, it's not related to HP brand only..

  • 4. Re: Printer jumps to pause whenever Macbook tries to print
    Alberto Ravasio Level 4 Level 4 (3,175 points)

    Are you sure?

     

    That is not a network printer with its own network interface card. It's a USB printer shared by the PowerMac G5.

  • 5. Re: Printer jumps to pause whenever Macbook tries to print
    Alberto Ravasio Level 4 Level 4 (3,175 points)

    Have you tried to remove and reinstall the printer from your wife's Macbook?

  • 6. Re: Printer jumps to pause whenever Macbook tries to print
    Alberto Ravasio Level 4 Level 4 (3,175 points)

    walterholt wrote:

     

    I have checked and rechecked System Prefs setting on both Macs in the Print & Fax Prefs section and the Sharing Prefs section to make certain sharing was on in both Macs.

     

    Only your PowerMac must have the printer sharing checkbox checked, because the printer is wired connected to your computer and YOU are sharing the printer among other users on your local network.

     

    However the URL is NOT the same for both macs in their Options Windows.    The Macbook's URL starts out  dnssd:// EPSON and then a string of % signs and names ending with  _ipp._tcp.local.       The URL in my Power Mac to which the printer is connected is shorter and reads usb://EPSON/Stylus%20C120?serial= and a long serial number.

     

    If you upgraded from Tiger, could be that the shared URI has changed. Go to the MacBook, remove the printer, add a new printer, make sure that Default is selected, choose the printer that pops up. Try printing.

  • 7. Re: Printer jumps to pause whenever Macbook tries to print
    walterholt Level 1 Level 1 (45 points)

    To all who who offerred info and advice.

     

    I greatly appreciate you comments and suggestions.  Somehow I solved the problem and the Macbook is now able to connect with my printer, but I don't know exactly what made the connection.

     

    I placed the Macbook next to my desktop G5 for more convienent testing without having to leave my desktop G5 and my USB attached Epson printer.

     

    I followed up on most of the suggestions. removed and adding the printers several times in both computer's system prefs.  Ran the built-in connection assistant, reset my router, changed the long USB 8 ft.cable on my attached printer for a 4 ft.cable, restarted both computers several times, and more, but now I can't remember just what.  I do know I spent about 4 hours fidling about.

     

    All of a sudden the Macbook connected to the printer and it worked so I just quit.  It has been 3 days now and everything seems to work just fine.

     

    I hope to add a "This helped me" star for each respoonse if I am allowed to do so.

     

    Thanks again to all.

     

    Walter