Skip navigation

cannot access icloud from my pc

5185 Views 30 Replies Latest reply: Mar 5, 2013 1:02 PM by MiamiBelle RSS
  • jmusci Calculating status...
    Currently Being Moderated
    Nov 13, 2012 7:24 AM (in response to stevehome)

    After hours of trouble-shooting with a 3rd level Apple technician, we finally concluded that there was something in my Internet Explorer that created this condition.  Apple walked me through all kinds of troubleshooting - disabling Norton Anti-virus, deleting cookies, etc and all without success.  Independently, I had downloaded Google's Chrome browser onto the laptop I was having issues with Internet Explorer, and my access issues to iCloud from this laptop went away. Apples explanation:  check with Microsoft, it is their browser and Apple does not support it!!

     

    However, my bigger - and original issue (as this "Can't load Calendar" was a new and additional issue) of iCloud not updating any of my Apple devices (iPhone 5, and iPod Touch) - is with Calendar events not being pushed from iCloud to my iPhone, and it still remains after a most recent two hour trouble-shooting session with Apple support.  It's now been 3 weeks since this issue was sent to "Apple engineers"for them to investigate, with NO RESPONSE back from these "backed up" Apple engineers.  With the latest trouble shooting, Apple support was able to isolate and prove that it isn't either of my Apple devices, but rather iCloud and my specific account.  (We created a new iCloud test account that was able to update iCloud calendar events back to my iPhone real time).  I've now turned my iCloud password over to Apple to investigate and fix my iCloud account issue - and have a follow-up call scheduled for Thursday November 15th.  I am not holding my breath...

  • erjdriver Calculating status...
    Currently Being Moderated
    Nov 14, 2012 7:33 AM (in response to urqu042)

    thanks very much, I have been having the same problem and Google Chrome has sorted it out for me!!

  • b52hbuff Calculating status...
    Currently Being Moderated
    Nov 14, 2012 11:02 AM (in response to erjdriver)

    I am experiencing a similar issue.  I have tried running internet explorer with add-ons disabled, and that seems to be a temporary workaround.

     

    From Windows 7 Start/Search box, type internet.  You'll get "Internet Exporer (No Add ons)".  Click on that, and open iCloud.com from that browser.

     

    Let me know if this works for you...

  • USMCTANK Calculating status...
    Currently Being Moderated
    Nov 14, 2012 2:20 PM (in response to urqu042)

    I've tried to use iCloud features on multiple computers (all PC, no Mac), on different networks, using different browsers including Internet Explorer (with and without disabling add-ons), Firefox, and Safari.  I've fully disabled Norton Internet Security software.  Nothing.  I continue to receive the "Unable to Load" error message when I attempt to use ANY of the iCloud apps (mail, contacts, calendar, notes, iWork, etc.) on a PC.

     

    Will be following-up with an Apple Help Desk technician again this evening.

  • Mike in Chantilly Calculating status...
    Currently Being Moderated
    Nov 14, 2012 2:45 PM (in response to urqu042)

    Downloading Safari to my Windows laptop solved the same issue. Doesn't make sense but oh well..

  • LvgGdsGrace Calculating status...
    Currently Being Moderated
    Nov 30, 2012 6:29 AM (in response to urqu042)

    I am having the same problem that started last week which is what brought me to this page desperately trying to figure out why all of a sudden it I could not access iCloud anymore. However my situation is a little different because I had been cleaning house and deleted some programs I wasn't using so I thought maybe I accidentally deleted something related to iCloud. So I ran a fix. It still didn't work. But during the same timeframe, I also reinstalled Norton 360 which had not been installed correctly and was not running all features. I now think it may possibly have something to do with that. I tried what b52hbuff suggested (IE with no add-ons) and it worked. I have not added anything else and I don't believe any other updates have been done except the Norton 360. If it is related, I really hope Apple fixes any compatibility issues. I don't want to work unprotected!

  • LvgGdsGrace Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 30, 2012 8:44 AM (in response to urqu042)

    I have figured out what is causing the issue...yay. It is Norton. It is the Vulnerability add-on. This add-on is with the 360 and Internet Security products (maybe more but those two I know for sure). Just click on tools in your IE toolbar. Click Internet Options > Programs > Manage Add-ons. Then scroll down until you find the Norton products. Click Vulnerability add-on and disable. Disabiling this feature does take a blanket of protection off your computer that you want to be there for everyday browsing and in general this add-on does slow the browser down in because it is doing its job to protect you. So basically, I suppose to get the best of both worlds, if I need to access icloud then i can disable the add-on to upload or download whatever I need and then re-enable it so I am getting the maximum protection. Even though at times, it almost feels as though I'm back to dial up because it slows my browser down so much but from what I have been reading...its all for a good cause. In a perfect world we wouldn't need to protect ourselves to such extremes, but unfortunately, this is not and will never be a perfect world. Good luck and blessing to all. I hope this helps someone.

  • USMCTANK Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 30, 2012 10:19 AM (in response to urqu042)

    Unfortunately LvgGdsGrace, your solution did not work for me.  I tried your recommendation with no success.  I have attempted to access iCloud from two different computers (one of which doesn't even have Norton 360 or NIS), and have tried using multiple browsers including IE, Firefox, and Safari.  I haven't tried Chrome, but at this point I refuse to download yet another browser.

     

    Anyway, thanks for the suggestion.  I give up.  I think I'll just cancel any additional storage for which I have to pay. Shame.

  • LvgGdsGrace Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 30, 2012 11:12 AM (in response to USMCTANK)

    USMCTANK, I am so sorry to hear that it didn't work. It's been working on my computer. Obviously there are several issues going on. Have you tried re-downloading icloud and selecting the fix option during the install. That is actually what I did first but then it was still doing it. Then I tried what b52hbuff had suggested and that worked so I started looking at the add-ons to see which one(s) would be causing the issue. I disabled a few others the first time but the 360 was the only one I re-enable to test it to see if it would not work again and it didn't so I figured that was the only one causing it. Hopefully Apple will figure this all out soon. Sorry I couldn't help. I tried

  • b52hbuff Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 30, 2012 4:16 PM (in response to USMCTANK)

    USMCTANK, did you try and disable all addons?  Try running Internet Explorer with all addons disabled.

  • b52hbuff Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 30, 2012 4:17 PM (in response to b52hbuff)

    One other comment for LvgGdsGrace, disabling *only* Norton Vulnerability appears to have solved my issue.  I'll wait a couple of months, reenable it and see if someone has fixed the bug.

  • Gerry S.. Calculating status...
    Currently Being Moderated
    Feb 1, 2013 5:52 AM (in response to b52hbuff)

    Just a quick note to this topic. I had this issue yesterday, using Firefox. This morning, iCloud was still giving me this message, to I cleared my cache (under History). Problem solved.

     

    From some of these reports, I don't think this will fix everyone's problem, but it's an easy step to take, and might solve the issue for others.

  • Csound1 Level 7 Level 7 (32,255 points)
    Currently Being Moderated
    Feb 1, 2013 6:23 AM (in response to bluesxman5)

    bluesxman5 wrote:

     

    Same here. Although I can get mail on my phone just not on my PC. Super frustrating. I just switched everything from Gmail so I can use the Cloud. I'm very much regretting it.

    Switch back.

  • Lindapcs Calculating status...
    Currently Being Moderated
    Feb 21, 2013 1:19 PM (in response to urqu042)

    I was having the same problem, came to this website, used Chrome and finally was able to resolve my problem. I had been using IE.  Thanks. 

  • Csound1 Level 7 Level 7 (32,255 points)
    Currently Being Moderated
    Feb 21, 2013 1:21 PM (in response to USMCTANK)

    Download Safari, disable any virus software and try again.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.