Skip navigation

I need to update my iMac. Please help!

453 Views 5 Replies Latest reply: Nov 16, 2012 1:58 PM by MlchaelLAX RSS
thebleuotter Calculating status...
Currently Being Moderated
Nov 14, 2012 4:13 PM

I have the 2004 model of iMac, which runs Mac OS X 10.3.9 Panther. I inherited it from a family member who passed recently, and I love it. I would like to get a great deal of use out of it. My question is how far can I upgrade it before I run into problems? If you need more information, please give a detailed instruction of how I get the system specs for my iMac. Please help. Thank you!

iMac, Mac OS X (10.3.x)
  • britny Level 1 Level 1 (125 points)
    Currently Being Moderated
    Nov 14, 2012 7:12 PM (in response to thebleuotter)

    i will try to answer some questions that others won't answer. love it you say? well that's a good start. what you won't be able to do is run flash videos on the internet and browsing will generally be slower. you also won't be able to run a lot of the newest software and the latest things that hook up to them. but older versions of ipods and software are available on the internet and work quite well for what they are designed to do. at this point you don't even want to buy a new printer without checking out the system requirements. to get a better internet experience you will need operating system 10.4 and you may get away with 10.5 if your system supports it even though 10.5 MAY slow your system down. at present i am using a 2002 g4 imac. i also have a g3 imac, am the original owner of both and i still like them as much as did ten years ago when i bought them. 2004? i'm guessing you own one of the early g5 imacs. these vintage macs still have a lot of life left in them but there will be some internet shortcomings both now and in the next few years. but older versions of itunes, iphoto, toast, appleworks, and some games will plug along just fine forever. along with a ton of other programs.

  • Rambling Joe Level 2 Level 2 (280 points)
    Currently Being Moderated
    Nov 14, 2012 10:30 PM (in response to thebleuotter)

    Does you iMac look like a half snowball base, with a metal rod connecting the base to the flat screen, or does it look like the entire computer is behind the flat screen and there is a bent, flat metal base coming out the back of the iMac?  The first one is the G4 iMac, the latter a G5 iMac.

     

    Go to the top left corner of your screen, and click on the Apple.  Pull down and click on About this Mac.  A small window will open that will tell you what version of OS X (something like 10.3.9) you're using, what the iMac's Processor is {something like 1.25 GHz PowerPC 7455 v3.3 (G4)}, and how much Memory (RAM) you have.  Write all that info down, the click on the button that says More Info...

     

    A new larger window will open, with a narrow column on the left, and a larger description field on the right.  At the very top left, Hardware will be automatically highlighted.  In the description field, the second or third line will say Model Identifier, and next to it, it will says something like PowerMac6,3 or PowerMac8,1.  Write that down.

     

    Comeback and provide us with what you wrote down, and we might be able to provide you more help.

     

    In the mean time, you can go to OWC (macsales.com) and look at possible hardware upgrades, to get an idea at costs for each item.  Here's a link to OWC:

     

    http://www.macsales.com/

     

    About 1.5 inches down from the top right corner of the website is a button marked Choose a Category.  Click it and select iMac Upgrades.  The webpage will automatically reopen to a page showing iMacs going back from 2011 to the Original iMac models.  About half way down the page should be your iMac. Use the Model Identifier you wrote down earlier and match it to the Machine ID listed next to the iMac model shown.  From there it will show you links to new Hard Drive, RAM upgrades, and other possible upgrades.  After you've looked through those, at the top left of the webpage, about 1.5 inches down is box marked Search.  Type PRAM Battery into the Search Box and click Go.  If you have the G4 (snowball) iMac, you'll need the 3.6 volt 1/2 AA Lithium battery.  If you have the G5 iMac, you'll need the 3 volt CR2032 watch/camera style battery.  You can pick these up at your local Walmart, Kmart, chain drugstore.  If you ever decide to open up you iMac to do a hardware upgrade, you might as well replace the PRAM battery since your iMac is 8 years old.

     

    Britny is correct, either model should be OS upgradable to OS 10.4.11 (Tiger), or OS 10.5.8 (Leopard).  Tiger might be a little faster on your old machine, but Leopard is a little better supported by 3rd party developers and could get you a newer browser version.  You'll need to search eBay for either OS.  Make sure you buy a disk(s) labeled as Full Retail Install Disk(s).  Some people try to sell the install disks that came with the iMac, but they only work on that specific model of iMac, and won't install on any other model.

     

    Good luck.

  • Allan Jones Level 7 Level 7 (29,570 points)
    Currently Being Moderated
    Nov 15, 2012 8:06 AM (in response to thebleuotter)

    but if I were to decide to upgrade to 10.5.8 (Leopard), would that be possible based on the specs I've given,

     

    No. The Leopard installer must detect a G4 processor that is at least 867mHz.

     

    I'm seeing myself using it mainly for basic internet browsing to check facebook, facebook chat, and checking my email.

     

    For e-mail, it's fine. Facebook and most modern web sites will not be happy. They use too many technologies that have left the PowerPC behind. My wife has a G4 1.42G eMac running 10.4.11 that does most things well but she now does most of her browsing and nearly all her Facebooking on an iPad 2--it's faster. The G-series Macs have been abandoned by web deveoplers.

     

    Our iMac G3/400 is a great word processor with programs that are from the same period. The real probelm in starting with an old Mac is that new software won't run on it. You need a stash of older program versions that are compatible.

     

    This version of the free Office-compatible productivity suite:

     

    http://www.libreoffice.org/download/?type=mac-ppc&lang=en-US&version=3.5.7

     

    say it will run on any PowerPC Mac as long as it hase OS 10.4.11,

  • MlchaelLAX Level 4 Level 4 (1,530 points)
    Currently Being Moderated
    Nov 16, 2012 1:58 PM (in response to thebleuotter)

    [post deleted by poster]

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.