Skip navigation

can't open google using any browsers in mac

4981 Views 20 Replies Latest reply: Mar 19, 2014 11:09 PM by graceberry RSS
1 2 Previous Next
Juliet zhang Calculating status...
Currently Being Moderated
Nov 14, 2012 8:45 AM

Recently I can't open google and any google related websites like google translate using my macbook pro.


I have tried different browsers, like firefox, safari and google chrome. None of them works.


Also, I tried different network. I have tried to open google under my home network, my office network and other public networks. None of them works.


And I have tried using Network Utility to tracerout. It can't stop and keep tracing. Shown as below.

Screen Shot 2012-11-14 at 11.40.58 AM.png

I have been struggling with this problem for couple of days.


Can anyone help me?


Thanks a lot!

MacBook Pro (13-inch Early 2011), Mac OS X (10.7.5)
1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.