Skip navigation

"Unable to quarantine" when copying large iPhoto DB

791 Views 12 Replies Latest reply: Apr 15, 2013 10:24 PM by Samurai6 RSS
Steffen4712 Calculating status...
Currently Being Moderated
Nov 15, 2012 12:04 PM

I have a large iPhoto Database, approx. 56 GB.


When I try to copy it to a NAS, the performance of the copy-process is horribly slow (estimated time shown: several days).


In Console I get hundreds of error messages like this:


12.11.12 20:36:14.000 kernel[0]: Finder[200] Unable to quarantine `c5BwOK5RT0mJtLlYgIik6A.apalbum': 22


12.11.12 20:43:52.000 kernel[0]: Finder[200] Unable to quarantine `50uHH8j7T4ORsQBpGAOrEA.apdetected': 22



When I stop the copying process it just hangs and I need to restart Finder.


When copying a single file, e.g. a 7.7GB mov-File, performance is good and now errors are shown.


Any ideas what this could be?




iMac, OS X Mountain Lion (10.8.2)
  • rkaufmann87 Level 8 Level 8 (40,615 points)

    The use of NAS's is not supported in OS X, I would recommend contacting the developer of your NAS and ensure you have up-to-date firware and software for it.

  • rkaufmann87 Level 8 Level 8 (40,615 points)

    Steffen4712 wrote:


    Are we talking about the same thing?

    With NAS I mean Network Attached Storage. I have a WD My Book Live which even offers support for TimeMachine out of the box.


    Btw, I did try several protocols: AFP, SMB, CIFS... no difference.




    Yes we are talking about the same thing. Apple only supports the Time Capsule as a NAS, any other external netowrk HD is only supported by the developer. Unless someone on this forum is knowlegeable about your WD My Book Live you need to contact the developer for support. IMO while most NAS solutions are generally OK the developers tend to fall behind when updates to OS X are made which is possibly what you are running into.

  • Jan Wessel Calculating status...



    Just my thought.

    An iPhoto Library consists of tons of files.

    (Go into the Finder, control click the Library and choose Show Packet Contents)

    If you copy it, it starts copying all the files inside the Library to the desired destination.


    Another issue, at least I am having a similar problem related to Aperture.


    Files can have "extra attributes"

    (Go into the Terminal and try the command xattr on a file)


    What probably is the case here, is that your NAS does not support extra attributes on files.


    So when Finder tries to copy, it also tries to copy the extra attributes.

    Which apparently is not possible.


    I do get the same error in my log on a single file, but it copies it anyway, so it might be that if you leave it copying it might end succesfully after all.

    Not sure about that though.





  • Terence Devlin Level 10 Level 10 (121,725 points)

    iPhoto needs to have the Library sitting on disk formatted Mac OS Extended (Journaled). Users with the Library sitting on disks otherwise formatted regularly report issues including, but not limited to, importing, saving edits, performance issues, crashing and sharing the photos.

  • Samurai6 Level 1 Level 1 (0 points)


    I have run into the same issue.

    I have an external NAS. I am trying to copy an 80GB iphoto library onto the NAS, and after running all night it has copied 450MB - only! - and it predicts 80 more days to complete the transfer...

    I have previously copied iphoto libraries of up to 7-8 GB with no issues.

    It seem there is an issue related specifically to the size of the file; I don't know if it is also linked to being iphoto library.


    Did you eventually find a workaround?


  • Jan Wessel Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 14, 2013 11:18 AM (in response to Samurai6)

    You must watch the following:

    A. An iPhoto library is not a single file, it consists of thousands of files, and all off these need to be copied separately


    B. The NAS (at least my WD Live Book Duo) is running a different File System than your Mac.

    This may cause no problems, as long as your application does not make use of any off the "extended attributes" that can be set on files.


    I had my referencdes files of my Aperture library on my NAS.

    When I deleted an image in my Aperture Library, up came a pop-up window saying "do you want to trash the referenced file also?"

    Replying "yes" resulted in the message that my NAS did not have a Trash, and the image was only deleted in the Aperture Library.

    Replying "no" resulted in the same thing.

    Which left me with lots of images on the NAS that had no reletion wih Aperture anymore.


    I am using a Thunderbolt device now, and that works like a charm.

  • Samurai6 Level 1 Level 1 (0 points)

    Hi Jan,


    Thanks for the response, but I don't think it us applicable to my context. For starters, I have already succesfully copied reasonable large iphoto files from my Mac to my NAS.

    By the way, this is a 'real' NAS, i.e; only a THECUS PRO only accessible through the router; for such large file transfers I use ethernet, connected through Samba.

    I let the transfer run all night, after 8 hours only 800 MBits were completed - that is ludicrous.


    Advice welcome!

  • LarryHN Level 9 Level 9 (54,870 points)
    Currently Being Moderated
    Apr 14, 2013 5:02 PM (in response to Samurai6)

    Very clear and simple advice - "Do not put your iPhoto library on a NAS" it is not supported and will cause problems - the iPhoto library must always be on a volume formatted Mac OS extgended (journaled)



  • rkaufmann87 Level 8 Level 8 (40,615 points)
    Currently Being Moderated
    Apr 14, 2013 6:54 PM (in response to LarryHN)

    Larryhn is 100% correct. Move the iPhoto library (an iTunes too) to an an external HD directly connected to the iMac. NASs in general do not work very well with OSX.

  • Old Toad Level 10 Level 10 (113,200 points)
    Currently Being Moderated
    Apr 15, 2013 9:01 AM (in response to Samurai6)

    Are you going to run the library from your NAS drive?  If so listen to the warnings already posted. iPhoto's makeup does not work with NAS drives.  It will result in damaged database files, messed up file access permissions on image files, etc.


    To just store/backup the library to the device isn't a good idea due to the potential file permissions issues. The problems you're having just with copying the library to the NAS drive should be warning enough.




  • Samurai6 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 15, 2013 10:24 PM (in response to Old Toad)

    Hi Old Toad, and everyone else.


    Thanks for the advice. I guess I'll stick to my external, portable hard drive (which is Mac OS X extended format).

    By the way, I couldn't delete the iPhoto file from my NAS with the mac, so I tried with a PC - and it went just fine. So it seems that there is indeed something wrong with the mac to NAS relationship.


    Thanks again



More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.