1 Reply Latest reply: Nov 15, 2012 2:01 PM by planb77
Charizma90 Level 1 Level 1 (0 points)

i have an older ipod itouch gen2 and i try to get new apps but says i have to update it first but there is no update options on it.


iPod touch, iOS 4.2