Skip navigation

Aperture not opening the library

771 Views 7 Replies Latest reply: Feb 1, 2013 8:14 AM by TStam RSS
crumrine Calculating status...
Currently Being Moderated
Nov 15, 2012 4:02 PM

I am running Aperture 3.4.3 on a MacPro running MacOS 10.7.5 and am unable to run Aperture.  When I launch Aperture it hangs with a dialog box open saying "Opening Aperture Library".  When looking at the menu bar, it is showing all the correct Aperture Menu's but I can't do anything because the library won't open.  I have tried repairing the premissions and repairing the library.  The only thing that seems to work is trashing Aperture and re-installing which is really annoying espcially since I do not have a MacApp store version.   This also seems to be happening on a weekly basis.  Any other suggestions for fixes would be much appriciated.

Aperture 3, Mac OS X (10.7.5)
  • Aye Es Oh Level 2 Level 2 (330 points)
    Currently Being Moderated
    Nov 15, 2012 4:26 PM (in response to crumrine)

    Do you have this issue with other libraries or only your main library? If other libraries are OK, I'd try working with a different library for a while to see if that eventually manifests the issue as well.

  • shuttersp33d Level 4 Level 4 (1,540 points)
    Currently Being Moderated
    Nov 15, 2012 4:26 PM (in response to crumrine)

    How long do you wait when it gives you the message that it is opening the library? Do you then force quit the application? Have you tried just letting it go?

  • Aye Es Oh Level 2 Level 2 (330 points)
    Currently Being Moderated
    Nov 16, 2012 8:36 AM (in response to crumrine)

    Does Aperture still stall when you use it in a different user account?

  • McGIO Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 25, 2012 5:11 PM (in response to crumrine)

    I am experiencing the same issue, any solutions?

  • TStam Level 1 Level 1 (75 points)
    Currently Being Moderated
    Feb 1, 2013 8:14 AM (in response to McGIO)

    Same happening here. I've tried every posted fix. Until now the only fix that worked for me was reinstalling Aperture and updates. For me I go about two weeks until the problem recurs. Very frustrating. It happened again today. This time I tried something different. I deleted the Aperture application and dragged the Aperture application from a backup I created yesterday back into my finder applications folder. The program launched right away.


    This means something is actually getting corrupted in the Aperture program file itself and not the library. Strange. While i'd prefer the program to just work correctly, my fix took about 3 seconds.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.