Skip navigation

Canon MX700 won't print on OSX Mt Lion

900 Views 6 Replies Latest reply: Nov 15, 2012 11:13 PM by libbeh RSS
libbeh Level 1 Level 1 (0 points)
Currently Being Moderated
Nov 15, 2012 1:42 AM

I am at my wits end with my Canon MX700. It won't print certain PDF files (through both Preview and Adobe Reader) and it will not print ANY text files (Word and Text file). It does prints text and pictures (no PDFs though) in Chrome, Safari, and Firefox.


I've uninstall and reinstall it many times, using various methods such as "resetting printing system" and uninstalling/reinstall the Canon MX drivers (both from Apple and Canon's website) and completely deleting the Canon folder in my HD>Library>Printers folder. Also have tried installing other MX printer drivers and still no luck. Same goes for previous versions of the MX700 printer drivers. I still cannot get certain file formats to print! Argh!! I am very frustrated because this printer is fairly new (it worked fine on my old Windows computer and had it stored away for years until recently). I have Windows partioned on Bootcamp, but even on Windows (through Bootcamp), the printer doesn't work. The printer itself works fine on my old Windows laptop, so I know it's not the printer. I'm no software engineer/expert, but I strongly think it's something with Apple's printer software since I am able to print on browsers.


I am runnning OS X 10.8.2 on my Mac Mini. I already updated to the most recent Canon printer drivers from Apple (Canon Printer Drivers v2.11 for OS X) and that still hasn't solved this printing issue. Was experiencing this issue prior to updating to the most recent drivers as well.


I consider myself fairly tech savvy, so feel free to suggest anything helpful, even if it involves some coding or whatever. Please help. I am really at my wits end, and as much as I'd love to punch and smash my Canon MX700 printer, purchasing a new printer is NOT an option, so I'd like to keep both printer & my sanity intact, thankyouverymuch.

Mac mini, OS X Mountain Lion (10.8.2)
  • sig Level 8 Level 8 (35,770 points)
    Currently Being Moderated
    Nov 15, 2012 4:05 AM (in response to libbeh)

    Have you tried deleting it from Print & Scan and then adding it back?

  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Nov 15, 2012 3:53 PM (in response to libbeh)

    Have you run a nozzle test? Maybe the black cartridge or head has failed. This would stop text from printing but not images - and also text on web pages which is often printed using a mixture of Magenta, Cyan and Yellow.

  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Nov 15, 2012 9:28 PM (in response to libbeh)

    libbeh wrote:


    Hi Pahu. I've read some of your answers to other Canon printer owners and they've helped those people, so hopefully you can help me out. I tried both a regular cleaning and deep cleaning as well as a nozzle test, but that didn't fix the printing issue. Same goes for a factory reset on the actual printer.

    So did the black ink appear with the nozzle test? If it did, then the black head/tank are okay.


    libbeh wrote:


    The only thing I think could be causing this specific printer issue is possibly the chip on the ink cartridges. They aren't authentic Canon ink cartriges, but they worked before (however, on my PC). I purchased the ink cartridges a few years ago (2006 to be exact), so it is possible that the chip is interfering with the printer being fully printing all documents?

    If the nozzle test does show the black ink then it won't be an issue with the cartridges.


    But if there is no black on the nozzle test, and the deep clean has not helped, then you may just need to purchase a new black cartridge. With you purchasing the cartridges in 2006 and having the printer stored for a period of time, then it is quite likely that the nozzles in the print head have dried up and stopping the ink flow.


    libbeh wrote:


    I'm kind of annoyed with myself that I didn't use this printer prior to upgrading from Snow Leopard to Lion to Mountain Lion since part of me thinks that the printer could be incompatible with Mountain Lion, but then again, I'm not a Mac expert. I'm computer/tech savvy, so any other suggestions you think may help (however "technical" it may be) would be much appreciated!

    The printer is compatible with Mountain Lion. If it wasn't, then it would not print at all.


    The other thing to note is that you have the same issue with your Windows partition via Bootcamp. If Windows was still printing but Mtn Lion wasn't, then there would be cause to blame the new version of OS X. But from what I have read it appears to be a physical machine issue rather than the OS.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.