Skip navigation

Sudden rMBP graphic performance issues

28475 Views 110 Replies Latest reply: Dec 16, 2013 11:31 AM by brsm1990 RSS
  • teggo Calculating status...
    Currently Being Moderated
    Oct 17, 2012 3:08 PM (in response to mtr64)

    Hmm okay, did you only reset it once after you made the updates? and are your issues in MacOS or Windows 7? I had to reset SMC once after doing this, but it's been two weeks now, without having to do a single SMC reset, whereas I had to do it daily before.

  • farfouillis92 Calculating status...
    Currently Being Moderated
    Oct 19, 2012 3:07 AM (in response to teggo)

    Hey guys, i actually have the same problem, and moreover i can't reset the SMC, it doesn't work on my MBPR...

    Do you have find any solution with Apple ?

  • Barnahog Calculating status...
    Currently Being Moderated
    Oct 30, 2012 2:25 PM (in response to farfouillis92)

    I'm also not getting any feedback when trying to reset the SMC. On my previous machines the Magsafe light would blink to orange, but I'm getting no change on my rMBP. Using left side shift+ctrl+option and power, and nothing.

     

    I had the graphics problem in Windows (also with Borderlands 2), and in OS X my GPU temps are very high (70-80ºC) in normal usage causing my fans to be spun up to 4k-6k RPM during basic usage. It used to rarely go above the 2K baseline. Driving me nuts.

  • Xaar Calculating status...
    Currently Being Moderated
    Nov 11, 2012 1:53 PM (in response to w00fa)

    Same issue here... I need to reset the SMC every time I want to play a game...

     

    Is this going to be fixed?

  • teggo Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 11, 2012 2:02 PM (in response to Xaar)

    Did you install the latest MacBook pro retina update from Apple? Was just released in the last couple of days. Just open App stor and click check for updates, it should show up there.

  • Barnahog Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 11, 2012 2:09 PM (in response to teggo)

    I've been testing it, and unfortunately it doesn't appear to have solved the problem. I still need to reset the SMC on each bootup to game, otherwise the performance is dramatically different. From smooth to unplayable.

     

    I don't believe the most recent update was an EFI update, where else the last EFI update seemed to be the cause of these issues. I'm guessing that until we get another this problem isn't going away.

  • teggo Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 11, 2012 2:22 PM (in response to Barnahog)

    Alrigth too bad

     

    Still haven't had this problem return since I updated my GFX drivers. Windows 7 and MacOS runs perfectly fine now and haven't had to SMC reset once, no matter how many games I play. Seems like there is more to this problem that I initially thought, wonder if there are some hardware differences in the different retina models that was sold this summer.

  • Xaar Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 12, 2012 2:57 PM (in response to teggo)

    I tried to install the Nvidia drivers but it did not work. I had to restore my Macbook Pro Retina from my TimeCapsule backup. I definitely would not recommend this manipulation ...

     

    I hope the problem will be fixed by Apple.

  • sinaxwe Calculating status...
    Currently Being Moderated
    Nov 16, 2012 3:29 AM (in response to Xaar)

    Just a question on the side.Has apple successfully resolved this issue for anyone? maybe a hardware repair or something? if so i will take mine into a store otherwise i wont bother as it is really inconvenient for me.

  • Dsacdalan Calculating status...
    Currently Being Moderated
    Nov 16, 2012 5:31 AM (in response to w00fa)

    I just got this problem yesterday, thought it was a hardware problem, but I will try the SMC fix once I get back to my dorm room.

  • mtr64 Calculating status...
    Currently Being Moderated
    Nov 16, 2012 6:42 AM (in response to sinaxwe)

    I took mine to the store and it was a complete waste of time since they do not know much about the problem yet. So all they could really do was a standard systems check to make sure everything was working ok. I did the driver updates mentioned on here about a month ago and I still have to reset my smc but not nearly as much as I used to.

  • tommyoliu Calculating status...
    Currently Being Moderated
    Nov 19, 2012 5:55 AM (in response to w00fa)

    Here is a conclusion of this bug from Hong Kong:

     

    I have had this issue with my rMBP bought in early launch period, i believe it is the first batch.

     

    Then, i bought another one with customization, which is believed is FRESH and a newer batch. NO SUCH ISSUE!

     

    I have compared this 2 machine with different batchs and here is the result:

     

    Cooler about 5-10 degree

    No throttling under load, both CPU & GPU

    use less power of CPU Package and CPU IA Cores according to AID64

    lower voltages of CPU Core

     

    3dmark 06 constant at around 15000

    3dmark 11 around 2500

    3dmark vantage around 10800

    with driver 306.97

     

    Are we just help Apple to improve their product at our cost?

  • tommyoliu Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 19, 2012 5:58 AM (in response to w00fa)

    Even it is at stock clock shown in GPU-Z, the one with bug has a lower GPU load in GPU-Z, don't know why...

  • tommyoliu Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 19, 2012 8:43 AM (in response to w00fa)

    Here is a conclusion of this bug from Hong Kong:

     

    I have had this issue with my rMBP bought in early launch period, i believe it is the first batch.

     

    Then, i bought another one with customization, which is believed is FRESH and a newer batch. NO SUCH ISSUE!

     

    I have compared this 2 machine with different batchs and here is the result:

     

    Cooler about 5-10 degree

    No throttling under load, both CPU & GPU

    use less power of CPU Package and CPU IA Cores according to AID64

    lower voltages of CPU Core

     

    3dmark 06 constant at around 15000

    3dmark 11 around 2500

    3dmark vantage around 10800

    with driver 306.97

     

    Are we just help Apple to improve their product at our cost?

  • Gav1nj Calculating status...
    Currently Being Moderated
    Nov 20, 2012 6:09 AM (in response to w00fa)

    i just got this issue over the last couple of days.  I noticed a huge 50% performance drop on black ops2 which was running at high detail 1080p with around 30-60 fps, i got this issue and my fps dropped down to 5-15.  I updated graphics drivers, rebuilt my whole bootcamp partition and the problem persisted.

     

    I found this thread and tried resetting my SMC and it worked first time, back to smooth gaming.  I hope i dont have to reset my SMC everytime.

     

    Hopefully Apple will release a proper fix, but at least the SMC reset works for now.

1 2 3 4 5 ... 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Related Articles

Bookmarked By (12)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.