Skip navigation

iTunes 10.7(21) 64-bit keeps prompt for Unable to load data class information from sync services

440 Views 0 Replies Latest reply: Nov 16, 2012 4:20 AM by jimmywj RSS
jimmywj Calculating status...
Currently Being Moderated
Nov 16, 2012 4:20 AM

I have just installed the xcode before I resync with iTunes.

iTunesError.png

I got this problem after sync with iTunes. 

 

My mac running 10.8.2 and latest iTunes 10.7 (21) 64bit.  I tried some advices from web but I have no luck:

 

1. Use sudo to remove the iTunes and resinstall it but it didn't fix the problem.

 

2. Use Timemachine to restore the AppleMobilexxx.kext and it also didn't fix the problem.

 

3. I tried to delete all backup ~/Library/Application Support/MobileSync/Backup/, no luck too.

 

4. I tried to reset the syncservices folder too http://support.apple.com/kb/TS1627

 

What else can I do now?

 

Regards,

Jimmy

iPhone 4, OS X Mountain Lion (10.8.2), iTunes on Mac

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.