Skip navigation

Since the last two updates to aperture 3, I've been unable to import my images directly from my camera onto aperture

177 Views 1 Reply Latest reply: Nov 16, 2012 4:45 AM by léonie RSS
katyblue79 Calculating status...
Currently Being Moderated
Nov 15, 2012 7:41 PM

Since upgrading to Aperture 3.42, I've been getting an error message every time I try to import photos directly from my camera into aperture. I now have to import the images into iphoto and transfer to aperture in order to edit pictures. I'd love to reinstall aperture and solve the problem but I have no faith that I'll be able to keep my 3rd party presets. Also, i lost my entire library of photos with that update. It erased ALL of them. 2 years of images gone. On the plus side, I've got tons of free space on my hard drive. Aperture 3 worked a million times better before all the updates.

Aperture 3, OS X Mountain Lion (10.8.2)
  • léonie Level 8 Level 8 (46,510 points)

    I've been getting an error message every time I try to import photos directly from my camera into aperture.

    What is the error message? Is there a crashlog? Then post the first  50 lines of the log, so we can see, what the problem is.

     

    Also, i lost my entire library of photos with that update. It erased ALL of them. 2 years of images gone.

    How can you tell that the images are gone? Does the Aperture library appear to be empty?

    • Sometimes Aperture creates a new library, that will open empty, but the old library is still there. To check, if you are viewing the correct library, hold down the options key, when you double click the aperture icon to launch Aperture. Does it show more than one library? Also, you can use Spotlight to search for packages with ".aplibrary" in the name. If you see more than one, try them all in turn, to see if one contains your images.
    • A second reason for missing images can be filters. Look carefully at the search fields in the library inspector and the browser, if these are showing "All items" or "Show all". If you see something else, clear the search fields. Each library item (project, album, folder) can have its own search field setting. You may need to clear them all.

     

    Regards

    Léonie

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.