Skip navigation

Problem with an iPhoto restore.

757 Views 4 Replies Latest reply: Nov 16, 2012 8:50 AM by wilfredfromcastleford RSS
wilfredfromcastleford Calculating status...
Currently Being Moderated
Nov 16, 2012 2:07 AM

Good Morning Folks,  I recently had my HDD replaced under the Apple scheme.  I restored everything succesfully from time Machine.  However for some reason I was convinced that I needed to reinstall iPhoto 11 (Don't ask).  So I did, now when I open iPhoto  I get a box saying that,

 

"You can’t open your current photo library using this version of iPhoto."

"You have made changes to your photo library using a newer version of iPhoto.

Do you want to quit and use the latest version of iPhoto, or do you want to create a new photo library?"

 

But it only gives me a box for "QUIT" I spent hours yesterday cataloguing and culling my library.   I've got all the photos but I don't know how to get back to where I was or why this has happened.  And I really quail at the thought of replicating yesterday's work.  Any help appreciated.  I'm using Snow Lepoard 10.6.8 on iMac 27 and I've installed all the updates this morning.  I don't know what newer version of iPhoto there is other that 11.

 

I've tried to use time Machine to go back to yesterday but

the 'RESTORE' arrow is greyed out.

All ideas gratefully received.Wilf

iMac, Mac OS X (10.6.8), iMac 11,1 Intel Core i5. 2.66GHz
  • Terence Devlin Level 10 Level 10 (121,695 points)
    Currently Being Moderated
    Nov 16, 2012 5:12 AM (in response to wilfredfromcastleford)

    There are many updates to iPhoto 11. What version do you have?

  • Terence Devlin Level 10 Level 10 (121,695 points)
    Currently Being Moderated
    Nov 16, 2012 5:58 AM (in response to wilfredfromcastleford)

    I believe that the latest version that runs on 10.6.8.

     

    Option 1

    Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Choose to Repair Database. If that doesn't help, then try again, this time using Rebuild Database.

     

    If that fails:

     

    Option 2

    Download iPhoto Library Manager and use its rebuild function. (In Library Manager it's the FIle -> Rebuild command)

     

     

    This will create an entirely new library. It will then copy (or try to) your photos and all the associated metadata and versions to this new Library, and arrange it as close as it can to what you had in the damaged Library. It does this based on information it finds in the iPhoto sharing mechanism - but that means that things not shared won't be there, so no slideshows, books or calendars, for instance - but it should get all your events, albums and keywords, faces and places back.

     

     

    Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one. 

    Regards

     

    TD 

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.