Skip navigation

OS X Leopard won't successfully install on my G5 tower

1024 Views 6 Replies Latest reply: Nov 17, 2012 5:22 PM by Henry G4 RSS
PowerPC_Fan Calculating status...
Currently Being Moderated
Nov 16, 2012 8:49 AM

I own a G5 tower (dual 2.0 Ghz processors, PCI-X, 6 GB of memory).  My question is this... my hard drive was on its last leg so I backed everything up, bought a new SATA 1TB hard drive and went through the typical reinstall steps. My Leopard install disk is the purchased version, not the factory included gray disks. I booted from the install disk, selected the disk utility and formatted my new disk for Mac compatibility, then went through the entire install process.

Upon restart the screen comes right back around to the OS X install screen, so the OS is not installing for reason.  I tried several times with the same result.  I tried this same process with my Tiger install disk with the exact same result.


Does anyone out there know what the problem might be?  Am I doing anything wrong?  I've done this type of thing before and have always had success.


Thanks in advance.

PowerMac, Mac OS X (10.5), G5 tower, dual 2.0 Ghz (PCI-X)
  • BDAqua Level 10 Level 10 (114,775 points)

    Hello, is the new Hard Drive SATA 1.5 Gb/s compatible?


    What brand/model drive is it?


    What shows as boot choices if you hold the alt key at bootup?

  • BDAqua Level 10 Level 10 (114,775 points)

    Does that matter?

    Absolutely, the symptoms so far sound a bit like it isn't.


    Without the Install Disc in, what shows as boot choices if you hold the alt key at bootup?

  • Neville Hillyer Level 4 Level 4 (1,845 points)

    Does this Mac normally boot from SATA drives. The reason I ask is because not all SATA drivers permit booting.


    Can you use the installer DVD to select the startup disk?

  • Bill Ross1 Calculating status...

    Try creating 2 partitions with disc utility 1st, one 160 gig the second with what ever is left over, then try to install mac os on the 160 partition.

  • Henry G4 Level 4 Level 4 (1,865 points)


    Without knowing the series of the drive (7200.11 or something like it) is very difficult to provide a definitive answer, however, I can tell you that some newer Seagate Barracuda SATA drives are probably not going to work, because they require the matherboard to have a speed autonegotiation SATA chip. I think (not 100% sure) these models are not compatible with your PowerMac:








    Some other (a bit older) Seagate Barracuda SATA drives have a jumper block, which will allow you to block the drive SATA bandwidth to 1.5Gbps like this:Picture 1.png

    which is exactly what the PowerMac G5 requires in order to properly recognize the hd.


    It would be great if you provide us with the exact Seagate HD model number.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.