Skip navigation

Mouse and trackpad just not working - can't use machine

386 Views 5 Replies Latest reply: Nov 16, 2012 4:55 PM by BDAqua RSS
TWH3 Calculating status...
Currently Being Moderated
Nov 16, 2012 11:33 AM

Hi there,

 

I have a late 2009 iMac running an up to date version of Mountain Lion and all has been well until today.

 

My iMac behaving very oddly with my trackpad. I have tried switching it our for a wired mouse and I get the same results. This is what I am experiencing:

 

The iMac behaves as though I have either:

  • clicked and held my finger down - on my desktop when  I move the cursor around the iMac thinks I'm trying to select an area
  • right clicked - when I try and click on an icon in the dock, the right click options appear

 

Additionally I am experiencing the following

  • iMac doesn't respond to me clicking on an icon
  • I can't select an option, ie if I do select an option such as 'Continue' (more of that later*) I  can't get the iMac to respond to me clicking it

 

Before switching over to my mouse I replaced the batteries in my BT keyboard and the trackpad. I've also tried attaching a USB keyboard (albeit a PC one)

 

I have tried the following:

  • resetting the V/P RAM
  • booting in Safe Mode
  • Shutting down, unplugging everything (inc power cord) and left for 10 mins before rebooting
  • Booting in recovery mode and reinstalling M Lion - I can't even do this

* When presented with the recovery options I can scroll through the 4 options with the up down arrow keys, I can select 'Continue' with the mouse or trackpad (it goes a solid blue colour) but I move forward - either by clicking it or hitting Enter on the keyboard.

 

I'm now totally stuck as when I reboot (there's been a fair few forced ones) I can't even select my user profile (or any of the Resart/Shut Down options)

 

Time to make a Genius Bar apppointment, or is there something else I can do?

 

Thanks

 

EDIT: I did manage to select my wife's user profile and eventually got into the system, and very strangley if I access the iMac via LogMeIn on my work PC it responds excatly as it should. I can click, select as normal. Even when I'm doing this remotely my trackpad and mouse continue to behave incorrectly (as described above

 

Message was edited by: TWH3

  • BDAqua Level 10 Level 10 (114,800 points)
    Currently Being Moderated
    Nov 16, 2012 12:44 PM (in response to TWH3)

    When you tried the USB PC KB, did you have wireless one off or batteries removed, sounds like it thinks a Modifier key is always pressed.

  • BDAqua Level 10 Level 10 (114,800 points)
    Currently Being Moderated
    Nov 16, 2012 2:53 PM (in response to TWH3)

    OK, good luck!

  • BDAqua Level 10 Level 10 (114,800 points)
    Currently Being Moderated
    Nov 16, 2012 4:55 PM (in response to TWH3)

    Good work, thanks for the report!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.