Skip navigation

Phantom Update Reminders

398 Views 8 Replies Latest reply: Nov 16, 2012 11:31 PM by tobacco_slammers RSS
tobacco_slammers Level 1 Level 1 (105 points)
Currently Being Moderated
Nov 13, 2012 1:17 PM

Hi all,


I am having the following issue:


Mac App Store advises that I have 2 updates available. When I open App Store it says Aperture Version 3.4.2 and iPhoto Version 9.4.2 are available. I already have these versions installed.


When I click on the update buttons it looks like it trys to install them again but when it reaches the end of the download I get "An error has occured". I am then asked to check via Purchasesfor the update and same thing happens.


How do I get rid of these phantom update reminders?


Below are screenshots:


Screen Shot 2012-11-12 at 20.34.27.png

Screen Shot 2012-11-12 at 20.34.37.png


I am currently on OS 10.8.2.





  • Dah•veed Level 7 Level 7 (29,555 points)
    Currently Being Moderated
    Nov 13, 2012 4:30 PM (in response to tobacco_slammers)

    Do you possibly have a backup drive connected that still has the older versions of these apps on it?


    Otherwise, you could try reindexing your HDD.

    Mac mini, OS X Mountain Lion (10.8.2), iPad 2, iPhone 5 (iOS 6)
  • Dah•veed Level 7 Level 7 (29,555 points)
    Currently Being Moderated
    Nov 13, 2012 11:06 PM (in response to tobacco_slammers)
    Mac mini, OS X Mountain Lion (10.8.2), iPad 2, iPhone 5 (iOS 6)
  • HACKINT0SH Level 5 Level 5 (5,750 points)
    Currently Being Moderated
    Nov 14, 2012 12:11 AM (in response to tobacco_slammers)

    The question isn't if the same version is installed on a backup, etc. It's if there is any chance of an older version archived somewhere, this is what messes up the MAS in many occasions. However, I don't quite think this is the problem, or at least the full problem, after looking at your screen shots.


    Let try this:


    Sign out of the MAS. Sign back in, then 'Check for Unfinished Downloads'.


    Works now? If not we can try a few other tricks.

  • mc2mc2 Calculating status...
    Currently Being Moderated
    Nov 16, 2012 7:25 AM (in response to HACKINT0SH)

    I've got a similar issue - but my button says "installed" but is greyed out.


    Strange stuff...


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.