Skip navigation

Aperture won't open iPhoto library

1190 Views 3 Replies Latest reply: Apr 7, 2013 8:23 AM by atryantaylor RSS
deedeefromtx Calculating status...
Currently Being Moderated
Nov 16, 2012 6:36 PM

I've been using Aperture for a few months now and haven't had any problems till tonight.  When I tried to open it I got the message "To open this iPhoto library in Aperture, it first nees to be upgraded.  Verify that you have iPhoto 9.3 or later.  Then open the library in iPhoto to upgrade it."  I checked for updates but I've got iPhoto 9.4.2.  How do I fix this?

MacBook Pro, Mac OS X (10.7.4)
  • léonie Level 8 Level 8 (46,450 points)
    Currently Being Moderated
    Nov 16, 2012 8:01 PM (in response to deedeefromtx)

    What is the type of library you are trying to open? Do you want to open an Aperture library with Aperture or an iPhoto Library, that you have been using with Aperture?

     

    If it is an iPhoto Library, do as the error message says and open the Library in iPhoto first to upgrade it to version 9.4.2:

    • Launch iPhoto with the options-key ⌥ held down and from the open panel select the library, that you want o open.
    • After opening and upgrading the library quit iPhoto again and now lauch Aperture again; also with the options-key ⌥ held down to select the library. Can you open it now?

     

    If opening and upgrading the library in iPhoto does not help, you probably need to repair the iPhoto Library package of the Library in question - perhaps the file "dataModel.plist" is damaged. To do this you will need to restore this file inside the Library from your backup - see this post by joeholmes:

    Re: Help! Can't Open Aperture Library (Requires iPhoto 9.4?)

     

    Regards

    Léonie

     

    11888

  • Hallcha Calculating status...
    Currently Being Moderated
    Jan 5, 2013 9:27 AM (in response to deedeefromtx)

    I was having a similar issue. 

    The cause was I had the Command set to iphoto. (Aperture>Commands>Iphoto>English) Once I switched it back to default(Aperture>Commands>Default>English), it allowed me to load my iphoto library without noting any upgrade of library needed.

    Hope this helps

  • atryantaylor Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 7, 2013 8:23 AM (in response to Hallcha)

    Thanks Hallcha, if you indeed switch that command and then go back in and choose command>import the library starts to load.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.