Skip navigation

EyeTV with Commercial Skipping HD DVR Server

21189 Views 117 Replies Latest reply: Apr 10, 2014 3:58 PM by davidb369 RSS Branched to a new discussion.
  • Ste88 Calculating status...
    Currently Being Moderated
    Nov 16, 2012 8:31 PM (in response to essandess)

    Thank you!

     

    X windows was working fine, but my wine was not. I installed winetricks and ran winetricks -v (verbose) and found an identical problem here: http://code.google.com/p/winetricks/issues/detail?id=163

     

    I also found a similar fix - removing and recreating my .wine directory in my home directory and re-running winetricks. Wine automatically sets up your new .wine directory and everything - awesome!

     

    I tried comskip from the command line, identical to the command I pasted before and it is now busy analyzing the show I selected! Next, I'll try and get everything automated with MarkCommericals.py, etc. I don't see why it won't work now.

     

    Thanks again,

    S

  • Ste88 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 17, 2012 8:03 PM (in response to essandess)

    Yep, now WINE is installed properly, the automation works too. It's beautiful.

     

    Since EyeTV's 10-foot user interface is pretty dreadful and I use the AppleTV as my main media hub I use EyeTV's export feature routinely. The lack of a decent commercial skip (even 30 seconds forward!) was frustrating and this makes my evenings a lot more pleasant!

     

    Thank you.

     

    All the best,
    S

  • chriser Calculating status...
    Currently Being Moderated
    Nov 19, 2012 9:25 PM (in response to essandess)

    I believe that I've been properly following your steps for Moutain Lion, but I can't get ETVComskip to install. I've installed Xcode, Xquartz, and Macports and I've run "sudo port selfupdate" After that I get these two issues:

     

    1. When I run "sudo port install wine-devel" I get these error messages: "Warning: The Command Line Tools for Xcode don't appear to be installed; most ports will likely fail to build. Warning: See http://guide.macports.org/chunked/installing.xcode.html for more information.

    --->  Computing dependencies for wine-develError: Unable to execute port: can't read "build.cmd": Failed to locate 'make' in path: '/opt/local/bin:/opt/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin' or at its MacPorts configuration time location, did you move it?

     

    2. When I run "Install ETVComskip" from the "ETVComskip-2.0.2-10.6" dmg I get the following pop-up error: "The operation couldn't be completed. (OSStatus error 100030.)"

     

    Thanks for your help!

     

    Chris

  • directtotim Calculating status...
    Currently Being Moderated
    Nov 30, 2012 10:10 PM (in response to essandess)

    @essandess

    I was wondering how you made this process work automatically:

    Record -> Transcode -> Mark Commercials [ -> Export to iTunes]

  • bebopbillybobeep Calculating status...
    Currently Being Moderated
    Jan 15, 2013 8:29 PM (in response to essandess)

    I've followed the discussion so far and installed everything, but I am getting this error:

    Screen Shot 2013-01-15 at 10.18.21 PM.png

    Any clues?

  • bebopbillybobeep Level 1 Level 1 (0 points)

    I shoud mention that all of these files exist. I'm wondering if there is a permissions error?

    I have two hard drives. One, a SSD, has the OS on it and the other, a HDD, has the User folders. Comskipper is installed on the OS drive in /LibraryApplication Support/, but my EyeTV recordings are stored in my user folder on the other drive.

     

    ls -l /Library/Application\ Support/ETVComskip/ComSkipper.app/Contents/Resources/lib/python2.5/lib-dynload/ objc/_objc.so
    -rw-r--r--@ 1 Jim  macports  659852 May 26  2010 /Library/Application Support/ETVComskip/ComSkipper.app/Contents/Resources/lib/python2.5/lib-dynload/ objc/_objc.so
    ls -l /usr/lib/libobjc.A.dylib
    -rwxr-xr-x  1 root  wheel  2486784 Nov  4 01:05 /usr/lib/libobjc.A.dylib
  • bebopbillybobeep Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 20, 2013 5:04 PM (in response to essandess)

    Ahh, yes...

    You are correct... Don't know how I missed that...

    Anyway, I downloaded and installed the latest version. I have to still test it and apply your improvements, but I don't get the error any longer.

    And FWIW, I am using 10.8 Mountain Lion...

     

    thanks.

  • rickfromwoodbury Calculating status...
    Currently Being Moderated
    Jan 27, 2013 4:38 PM (in response to essandess)

    essandess,

     

    What do you mean in your instructions:

     

    Edit the file ./MarkCommercials.app/Contents/Resources/MarkCommercials.py to use WINE to run comskip.exe nicely. Grep for these changes:

     

    What does one do to Grep?

     

    Thanks,

1 2 3 4 5 ... 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (11)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.