2 Replies Latest reply: Nov 17, 2012 6:21 AM by anrhie2003
anrhie2003 Level 1 Level 1 (0 points)

I just upgraded to imovie 11 and it's taking forever to load my photos from iphoto even after deleting my videos. it's rendering the program useless


MacBook Pro, OS X Mountain Lion (10.8.2)
  • 1. Re: iphoto loading forever
    Bengt Wärleby Level 6 Level 6 (19,160 points)

    Hi

     

    There are many things that happens when upgrading (Application and Mac OS).

     

    And it needs LOT'S of time !

     

    I would if in Your situation do all these steps - Not just one and test as things can get even more complex by doing that.

     

    • Trash iMovie Pref file (In User Library / Preferences - Not Library on Root level (the one You see when opening Your Hard Disk - USE the GO function above if it is hidden (Mac OS X.7 and 8 - it is)

     

    • Run Repair Permissions - Disk Util tool

     

    • Start iPhoto - YES iPhoto - but keep down alt-key and cmd-key - and select a full repair - THIS WILL take Hours to do - BUT as iMovie in Start-Up tries to find Your Photos and Videos stored in iPhoto - if this has any error - iMovie get severely STUCK

     

    If PowerBook (Lap-top) Keep Mains-adaptor connected - so that You not run out of battery.

     

    Good Luck

     

    Yours Bengt W

  • 2. Re: iphoto loading forever
    anrhie2003 Level 1 Level 1 (0 points)

    Thanks, i've done what you suggested, and still waiting to for iphoto images to load on my imovie. i guess i'll try to wait for it to load until tomorrow, but if that doesn't work, then will just trash the app.