Skip navigation

Photoshop Elements 11 won't roundtrip in Aperture

814 Views 3 Replies Latest reply: Nov 17, 2012 9:20 AM by Bill Veeser RSS
Bill Veeser Level 1 Level 1 (20 points)
Currently Being Moderated
Nov 17, 2012 6:45 AM

I just purchased Photoshop Elements 11, installed it, selected it in the Aperture preferences, restarted Aperture and tried to edit an Aperture photo using the new Photoshop Elements 11.  From Apertures  "photos" menu I selected edit with Photoshop Elements  11.  Aperture created a new version and opened Photoshop Elements 11, but my photo file did not open in Photoshop Elements so could not edit it from Elements.  Anyone else have the same problem?  Ant suggestions appreciated.

MacBook Pro, OS X Mountain Lion (10.8.2), Aperture 3.4


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.