Skip navigation

Push Notifications Stop Working

973 Views 4 Replies Latest reply: Nov 17, 2012 12:37 PM by msmitasi RSS
noahs Level 1 Level 1 (15 points)
Currently Being Moderated
Sep 25, 2012 4:56 PM

I'm having a problem receiving push notifications on my iPhone 5 (Verizon). This affects push email (iCloud and Exchange), iMessage, and third-party apps. Push notifications will work normally for some period of time (on average, a few hours, sometimes less) and then stop working. Toggling airplane mode or restarting the phone will restart the push notifications service and temporarily fix the problem. But it then recurs. I've tried resetting network settings and backing up & restoring the phone, but the problem recurs.

 

I've also noticed that the apsd process is crashing on my phone. APSD is the Apple Push Service Daemon. It seems every few hours or so, it crashes with exception EXC_CRASH (SIGABRT), and the phone stops displaying push notifications. You can see the crash logs in Settings-->General-->About-->Diagnostics & Usage-->Diagnostic & Usage Data.

 

I have no problems (and no similar crash logs) on my iPhone 4S (AT&T)  and iPad 3rd-gen (Verizon), both of which are running iOS 6. Is anyone else having similar issues and has anyone gotten a response from Apple?

iPhone 5, iOS 6
  • TechIntrovert Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 5, 2012 1:37 PM (in response to noahs)

    I have the same problem. I've scoured the web for an answer and found others with the same issue, but no solution. I've tried restoring using iTunes with no luck.

  • msmitasi Calculating status...
    Currently Being Moderated
    Nov 17, 2012 9:19 AM (in response to noahs)

    Same problem, wiped and restored phone and it fixed it temporarily (just like restarting or toggling airplane mode would). Only seems to affect my corporate Exchange account, as I have my Gmail account added as an Exchange account to take advantage of Push and Contact syncing and it continues to work fine. I tested with another iPhone 5 in our organization and it has been working fine since the user got it.

     

    However, I don't see APSD in Diagnostic & Usage Data, I'm not sure how long that log is kept but it has stopped working twice since I performed a restore on the phone, last night and again this morning (only a few minutes after I restarted).

     

    iPhone 5

    Verizon 13.3

    Version 6.0.1 (10A525)

    Model: MD654LL

    Modem Firmware: 1.01.00

     

    Am going to try wiping and setting it up as a new phone.

  • TechIntrovert Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 17, 2012 9:23 AM (in response to noahs)

    I was able to get this resolved. Restoring from either iCloud or iTunes backup did not help. I had to setup as a new phone and re-enter my mail account info from scratch.

  • msmitasi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 17, 2012 12:37 PM (in response to TechIntrovert)

    Unfortunately, setting it up as a new phone does not seem to have worked for me. Gmail push is still working, corporate Exchange is not. It's been less than 3 hours since I re-set it up as a new phone.

     

    We're using Exchange 2007 in a 2k3 domain with a separate CAS. Doesn't seem to make a difference if I'm on Verizon LTE, corporate wireless (HP and Aruba WAPs), home wireless or VPN'd in.

     

    (Edit: There's a 41 page thread about this issue dating back to September and there doesn't appear to be a permanent fix yet: https://discussions.apple.com/thread/4345374?start=600&tstart=0)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.