Skip navigation

iphoto lost all photos - request to server failed?

1871 Views 41 Replies Latest reply: Nov 17, 2012 11:12 AM by joeyjohnson RSS
  • steve626 Level 4 Level 4 (1,395 points)

    Your symptoms, as others have noted, are disturbing. The partition map is what the operating system uses to find files (and pieces of files -- files are not stored contiguously on the disk). Not sure why one type of Disk Utility run finds nothing wrong and the other finds something wrong, but that's indicative of something wrong. By the way, are you using File Vault? (If so, that complicates all this to some degree.)


    I have read that running disk repair/verify from an externally booted disk or from the recovery disk is more reliable than running disk utility "in place" while booted from the disk in question. However in conjunction with your other problematic symptoms, clearly something is wrong.


    I also noted earlier that this is an ebay-purchased computer. Don't take this the wrong way, but often ebay is where people unload things that aren't working right for them. I wonder if the previous owner encountered the same issues and decided simply to sell the machine so someone else could try to deal with them ... (like you)


    Given that it is from ebay, have you checked the hardware of this Mac with the Hardware Test program that is on the recovery disk? That could be a source of the problems, hopefully not.


    I think your best bet is to make two backups (that's for redundancy) of your user folder contents. Try to make sure you can find and browse those files from the backups. Then I would obtain Disk Warrior and run it to try to fix any problems. Disk Warrior will find and fix things that Apple utilities cannot. If that works, you might be ready to go. If Disk Warrior says things are fine, that would then point to either hardware problems inside the Mac, or a damaged system installation. For the latter, you could try the latest combo update reapplying it, or a fresh installation of the OS. If that doesn't cure what you have, I'd completely reformat the disk and reinstall a fresh operating system and software that you have, and then restore your user folder from your backup(s).


    If you have file vault turned on, I'd turn if off for now until everything is working right again.


    One last thing -- when you go to Apple for test/diagnosis, they often will end up doing a complete reformat of the disk, so it's extra important to backup your files as best you can. If the partition map is broken, you may have trouble finding and backing up all your files, but I'm not totally convinced that your partitiion map is broken, you have contradictory indications.


    I think your iPhoto issues have to wait until you get a reliable system running. The iPhoto and Safari programs might be damaged, for instance, it's hard to say. Your photos are physically there, they are not lost, but the iPhoto database may be having trouble finding them. They can be re-imported into a new iPhoto Library but don't do that until your system is stable. You can see the actual photo files by right clicking on the iPhoto Library to Show Package Contents, and then you'll see some folders, the one called "Originals" has your original photo files, other folders will have changed or modified photo files. They are all there, but the database may be damaged and thus unable to locate the photo files. That can be fixed in a variety of ways, but not worth doing until yur system is fixed.

  • steve626 Level 4 Level 4 (1,395 points)

    Sounds like there are many other bits of information that you just provided that may also be relevant! Very hard to try to disgnose this remotely like this. However, here are some suggestions:


    Apple Hardware Test. Please see this Apple article:  it tells how to run the Apple Hardware Tests. I think it requires booting while holding down the D key, but see the article for instructions, especially the part about Lion OS computers. My computers are running 10.6 so I don't have direct experience with this new Lion verison of the Hardware Test.

    I think you should run this test because (1) of the disk error you consistently got from Disk Utility and (2) something like a bad memory chip or other hardware issue could easily explain all your symptoms. I'd run the extended hardware tests, especially for memory. It can take hours.


    When you reformatted your disk, did you do it writing zeros throughout (might take many hours on a 1 TB drive) in order to identify and map out any bad blocks? (Grasping here, but a bad block or two could cause odd symptoms.)


    Holding down Option when booting might not provide you with the choice of boot disks because of having File Vault turned on. File Vault can be prone to file or disk corruption, more so than computers not using File Vault. I'd turn off File Vault for now (and maybe forever).


    Have you tried booting into Safe Mode and then trying to use your computer (some things won't be enabled in Safe Mode) to see if the various symptoms go away? If they do go away, that might point to a problematic extension that you have installed. Even an odd or corrupted font, for instance. 


    Keep in mind that your painstakingly careful migrations by hand may have inadvertently brought over a problematic extension or preference file from an old corrupted system, which then could have corrupted your newly installed system.


    Have you created a new user and seen if the new, "blank" user encounters the problems you saw with Safari, iTunes, etc.? Again, if you have a damagedd disk or memory chip, all users would see these things, even in safe mode.


    As for Time Machine, your system logs (you can view them in Console) show what happened with Time Machine. Have you tried just manually starting a new Time Machine backup and seeing how it goes?


    Disk Warrior can fix partition map problems that Apple Disk Utility cannot fix. I have seen this in person so I know it is true. If you can't afford to get it, then I guess that's that, but it might be the only way to resolve your issue (although it's hard to tell exactly what your issue[s] is/are right now).


    I think reading stories like this is why I avoid ebay for relatively new computers. Why would someone sell a good, working, relatively new and up to date computer on ebay? It's good that you have the warranty still, but you still have to deal with the situation, which is a big hassle generally. If you can't afford tools like Disk Warrior, I'd take it in to the Apple people to examine and test (back up your files first).

  • steve626 Level 4 Level 4 (1,395 points)
    Currently Being Moderated
    Jun 4, 2012 10:00 AM (in response to steve626)

    A few more things:


    Your permissions repair item looks innocuous to me.


    You mentioned earlier that you upgraded the RAM to 12 GB. Did you do this yourself? Where did the RAM come from? Are you mixing different types or sizes of RAM? Any details on how that went? Faulty or mismatched RAM (just one stick even) could easily cause all your symptoms. Maybe that's not the issue, but did you have these symptoms before the RAM upgrade?


    Another question: how did you reinstall the operating system when you did that?


    All your issues could stem from one cause. On the other hand, I am worried you have more than one issue, e.g. RAM problem plus hard disk problem plus ... Makes it harder to resolve.

  • BDAqua Level 10 Level 10 (114,715 points)

      permErr                       = -54,  /*permissions error (on file open)*/

1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.