2 Replies Latest reply: Nov 17, 2012 2:54 PM by Bazza144
Bazza144 Level 1 Level 1 (0 points)

Imovie will just not work. I cannot reinstall as my ilfe license expired in March and its had all the updates recently. Within 10 seconds of stsrting it stops and goes into notv respoinding mode. I have reset all permissions but will no joy any advice please. I am opertaing OX S 10.8.2 on my Imac


iMac, OS X Mountain Lion (10.8.2)
  • 1. Re: IMOVIE not responding
    Bengt Wärleby Level 6 Level 6 (19,155 points)

    Hi

     

    When iMovie doesn't work as intended this can be due to a lot of reasons

     

    • iMovie Pref files got corrupted - trash it/they and iMovie makes new and error free one's

    • Creating a new User-Account and log into this - forces iMovie to create all pref. files new and error free

    • Event or Project got corrupted - try to make a copy and repair

    • a codec is used that doesn't work

    • problem in iMovie Cache folder - trash Cache.mov and Cache.plist

    • version miss match of QuickTime Player / iMovie / iDVD

    • preferences are wrong - Repair Preferences

    • other hard disk problem - Repair Hard Disk (Disk Util tool - but start Mac from ext HD or DVD)

    • External hard disks - MUST BE - Mac OS Extended (hfs) formatted to work with Video

    ( UNIX/DOS/FAT32/Mac OS Exchange - works for most other things - but not for Video )

    • USB-flash-memories do not work

    • Net-work connected hard disks - do not work

    • iPhoto Library got problems - let iPhoto select another one or repair it. Re-build this first then try to re-start iMovie.

    This You do by

    _ close iPhoto

    _ on start up of iPhoto - Keep {cmd and alt-keys down}

    _ now select all five options presented

    _ WAIT a long long time

     

    • free space on Start-Up (Mac OS) hard disk to low (<1Gb) - I never go under 25Gb free space for SD-Video (4-5 times more for HD)

    • external devices interferes - turn off Mac - disconnect all of them and - Start up again and re-try

    • GarageBand fix - start GB - play a few notes - Close it again and now try iMovie

    • Screen must be set to million-colors

    • Third-party plug-ins doesn't work OK

    • Run "Cache Out X", clear out all caches and restarts the Mac

    • Let Your Mac be turned on during one night. At about midnight there is a set of maintenance programs that runs and tidying up. This might help

    • Turn off Your Mac - and disconnect Mains - for about 20-30 minutes - at least this resets the FireWire port.

    • In QuickTime - DivX, 3ivx codec, Flip4Mac, Perian etc - might be problematic - temporarily move them out and re-try

    (I deleted the file "3ivxVideoCodec.component" located in Mac HD/Library/Quicktime and this resolved my issue.)

     

    buenrodri wrote

    I solved the problem by removing the file: 3ivxVideoCodec.component. after that, up-dated iMovie runs ok.

     

    Last resort: Trash all of iMovie and re-install it

     

    Yours Bengt W

  • 2. Re: IMOVIE not responding
    Bazza144 Level 1 Level 1 (0 points)

    How do I remove the file 3ivxVideoCodec.component